Hello All,

Getting a setup going. Everything appears to be working well, except the throttle.

Obviously, going straight into the Rx works just fine.

The ESC normally plays a startup tone, and then 3 beeps to let me know it's ready. It does this when going straight into the Rx.

If I jump the Rx into the "in" side of ardupilot.

And hook the ESC into channel 3 on "out" side.

I get the startup tone, but not the following three beeps.

Has anyone else experienced something like this?

I've quadruple checked the servo connections, and they're correct.

Any suggestions?

Thank you!

John C.

Views: 1086

Reply to This

Replies to This Discussion

Gotcha, now I understand what the wire really does.

I thought it just passed power to the rest of the board.

I appreciate it guys! I'll let you know how it works.

John C.
That was the ticket.

Seems that everything checks out now! Pitot tube works, manual works, RTL seems to work.

Put a freshly built aileron ez* into the air today (without AP installed). First time I've ever flown a plane with ailerons. With a dual-rate set to 50, it was surprisingly like a stock rudder-only ez* (except the 2200kv brushless...woah...stock ez* speed is 1/4 throttle on this thing.)

Anyway, time to learn the config tool, and then start tinkering with it in the air. I certainly appreciate the help!

Glad to hear it! Let us know how it goes...
I don't think this is an isolated issue as I had exactly the same problem with mux 3 and only found out recently when I started using throttle. Thanks to this post I also fixed it using mux 4.
I think the MUX chip is somewhat "fragile". I lost channel 3 on mine as well and attribute it to ElectroStatic Discharge. It could have been due to some other cause I suppose.
I have a similar throttle issue and was wondering if you thought it might be the MUX. I have throttle control in MANUAL mode, but as soon as I switch to STABILIZE or FLY_BY_WIRE_A, the throttle cuts off. I have tried different board configurations (with and without the Shield) using the IMU and have watched the plane correct its attitude, but the throttle cuts off and I cannot override it with the controller. As soon as I switch back to MANUAL mode, throttle control returns.
Any ideas?
Problem solved, it was not the MUX. Had to connect my setup to a separate receiver battery instead of powering it from the ESC BEC.
Thanks for the update! Was your ArduPilot power solder jumper switched to BATT?
No, when I received the board the PSEL solder jumper was not connected to either BATT or SVRO. I connected the jumper to SVRO using power from the ESC which was cutting off the engine when I switched to any of the other modes besides manual (it was also giving errors running the throttle test code where none of the throttle numbers in the serial window were moving in response to the throttle control movement even though the actual throttle output was changing).
I now have the board, servos and receiver connected to a receiver battery and am using jumpers for signal and ground to connect the engine control to the board output. It appears to work this way and I had a more successful test flying today. The engine did not cut off in STABILIZE, FLY_BY_WIRE_A, or RTL but I still need to work on adjusting my PID and other header file settings.
Do you have any suggestions or recommendations to improve this setup? Thanks for the help.
I am having the same issue with throttle in manual, using a servo on the channel 3 out.

Would another symptom of a fried mux channel 3 be this:

My throttle works in Stabilize, and Other modes except Manual mode?

I have had this ardupilot working fine for months with many flights on it.
I recently made some code changes and now I have this throttle issue.

I am going to read resistance though the mux to see if I have a open.

Yep all is well channel 3 thru the mux is fried. Works fine when i put thru channel 4.

I have also the same issue on 2 AP boards in parallel. Very strange: Could be an ESD issue, but probability is not high. Could be an ESC issue as well. I will try to measure and find out and keep you posted.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service