Hi All,

I have been testing out 2.26 (APM 1.0.95) in the various failsafe modes, and have found that if the radio goes to failsafe (via throttle) when the Arduplane is in manual mode, it as per the code indicates, should go to circle mode. It is hard to know, as the mode indication does not change. After 20 secs the mode changes to RTL, so basically it seems to be OK. However if the FS mode is triggered whilst in the manual state the throttle falls back to 0, and there is no pitch  or roll correction from servos if the plane is tilted. It as if the aurduplane is still in manual. What is intersting is that looking at the "Raw Sensor-Radio" window, it shows that the Ch3 out indication has been set to the throttle cruise position and when the plane is tilted, the correct compensation is showing up on the roll and pitch radio out bars. It is just not getting ot the servos. After 20 secs, RTL is shown as the new mode, but still the servos do nothing.

This is behaviour is repeatable, and would indicate that if the radio is lost the plane will minimise the throttle, and glide to the ground either gracefully or not depending on the glide angle.

In any of the other mode such as stabilize of FBW the FS process seems to work, however the initial change to "Circle" is not reported, and I wonder it is really changing to that mode, the roll servo appears to change as soon as the short FS is triggered which tends to indicate it is initiating a circle.

 

Just one other noteworthy point is that the roll servo after a FBW-A to FS short event occurs, does not return to neutral if the FS is cancelled before FS long occurs. I.e. for FBW-A to FS short, the roll servos moves, but from FS short back to FBW-A it just stays in the new position. The mode needs to be toogled to return the servo to neutral. This does not occur in stabilize mode, as the roll servo does return to neutral on FS short back to stabilize.

 

All good fun!!

Love to hear of any other similar findings.

Cheers

Steve

Views: 376

Reply to This

Replies to This Discussion

Just answering my own question for anybody that is interested.

Have found out (should have known really) that the Manual mode I was is was in fact the PWM MUX hardware failsafe (ie ch8>1800ms or mode 6 if you like), so the ardupilot was not in the servo control loop at all. When I set the throttle to failsafe (<950ms), Ardupilot has no access to the servo outputs and hence the servos did not respond to Ardupilot commands.

Another point to note is that the failsafe mode has some logic built in so that if Ardupilot considers that the plane is at home on the ground, then if it goes to throttle failsafe, Ardupilot will force the throttle to zero. This tripped me up when testing throttle failsafe on the bench.

 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service