ArduPlane 2.60 released

I've just released ArduPlane 2.60

The main new features in this release are:

  • wind estimation
  • long term dead reckoning support
  • wheeled takeoff and landing support
  • optional new roll/pitch/yaw controllers from Jon Challinger

For a description of the first 3 new features have a look at my previous post. All of these features have been test flown on my PulseXT 40 and have performed very well.

The new roll/pitch/yaw controllers from Jon can be enabled by building with


in your APM_Config.h. If you enable the new controllers then I strongly suggest you read Jons blog post about the new controllers and how to tune them. These controllers are still experimental, but if we get good feedback on them from users we will quite likely adopt them as the standard controllers in a future release.

Other changes in 2.60 include:

  • a new RECEIVER_RSSI_PIN compile time option, to allow you to display receiver RSSI via MAVLink. This should be useful for FPV flying.
  • an important fix from Jason Short for an erase bug in the dataflash. If you use dataflash logs then please erase them after loading this release to ensure the pages are properly initialised.
  • support for the new features in the new MTK GPS firmware
  • updates to the configuration parameters for the Mount code. If you use the mount code, then please check your parameters carefully, as some things have changed.
  • a fix to the JUMP command in missions, which solved a problem where the wrong command could sometimes be run
  • a fix to the initial yaw from AHRS when using a compass
  • new "OBC" failsafe code as a compile time option
  • new RST_MISSION_CH option
  • new STICK_MIXING option
  • support for dual stabilisation mounts (eg. one camera and one antenna)
  • removed old CLI switch and dip switch support
  • fixed a derivative filter bug that could have a small affect on AHRS attitude
  • fixed LOITER_TIME to match MAVLink spec (time is in seconds)
  • added FBWB_ELEV_REV option

Happy flying!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi,

    I am recently using the ArduPlane 2.6 code (MP 1.2.9) with my APM1.4 and noticed a strange behaviour when looping a path with the do_jump command. EEPROM was erased before loading AP2.6, APM was reset.

    Now, this is how I programmed the mission:





    do_jump to WP1

    WP6 (fake)

    WP7 (fake)

    This is what the plane does:





    HOME, moves towards ground altitude but as I have put HOME in between the WP4-WP1 path, after it reached HOME (descending), it goes further to WP1 and repeat above cycle.

    So somehow the home location gets in between the WPs while looping.

    I am attaching the log files, I hope someone can have a look.

    thanks in advance


    2012-09-08 08-58-19.tlog

    2012-09-08 22-14 42.log
  • Hallo,

    can somebody clarify to me what movement orientation is intended for rudder control surface?

    For instance when APM is in stabilize mode and the plane is leveled then I move the plane in roll axis -> left wing down, right up. What direction is supposed rudder to move?

    Now I have set it to move right as I used to do when flying with usual acro planes: roll left, rudder right to make knife flight.

    This is but different with glider planes, there it is contrary: roll left, rudder slightly left.

    So what rudder direction needs APM software for correct stabilization?

  • I'm working on resolving an issue in FBW-A mode. While testing FBW-A and stabilize the airplane turns right maintains the proper bank and holds altitude. When I bank to the left it initially holds alt for about 1 sec, you can see the pitch increase but then it sharply looses altitude in both FBW-A and Stabilize. I'm not sure what values i should be looking at. I have rudder comp set to .5 and pitch comp .8. I've tried increasing pitch comp and it results in a altitude increase upon moving the stick left or right to bank. Both left and right seem to be holding the bank.

    What values should I be looking at modifying?



  • This question was posted by Mike back on page 3 and doesn't seem to have been answered.

    "Where can I find more information about the "support for the new features in the new MTK GPS firmware" new feature?"

    Is this just 1.6 or is there a newer version available?


  • I'm having a problem with GPS not being recognized with 2.6 on 2 different APM1.4/1280 boards. I've tried 4 GPS units but am getting nowhere! I've put the details here and would appreciate if anyone has any clue to how I can solve this. I can't even get into terminal mode on either so my testing is limited.

  • DO_REPEAT_SERVO not work.

    Hi Andrew, I'm making with evidence; DO_REPEAT_SERVO command but does not work in arduplane 2.6, when I use this command HIL sumilador funcioan well.

    special settings for this command?


  • Looks like Mission Planner 1.2.10 has solved all my Write Mission problems with 2.6. I suspect that it was some sort of a timing problem?

  • I just installed 2.6 on a APM1.4 and am having problems entering CLI mode. I tried 3 returns which normally work but instead it just shows text saying that it's initializing demo servos and then calibrating IMU and then ready for flight. What would prevent it from entering CLI mode or is there some other way I can enter it? I've tried the switch on the board that use to be used but that didn't work either. I have a thread started in the arduplane group.

  • Today I tested my SW168 with Arduplane 2.6.

    It flu twice.

    First way was almost 7km long with 8 waypoints. Last WP was LOITER_UNLIM. No problems on that.

    Second trip was only 3.4km long with 4WPs but 300 meters camber. It was way there and back. Again no problems with it.

    The only word I can say is reliable and with suggested parameters from WIKI/APM for SW168 flies really good and stable.

    Good works guys, thanks for the version 2.6. 

    Remarkable is my APM1 is only 1280 so memory limits are unpleasant, no logs, hardcoded GPS_PROTOCOL, no CLI, etc. And with this memory limits and Arduplane 2.6 it flies really good.

  • I tested ArduPlane 2.6 this morning with APM2.0 mounted in my SkyFly Max.  I ran into two fairly major issues.  I can never be sure if I'm doing something wrong or if there are, in fact, bugs, but I'll post these items in order to learn or to help.  There was actually some drama in that I nearly lost my plane.  I don't mean lost as in crashed necessarily, I mean lost as in where the heck is it!

    After loading a simple 4-point pattern around the field with a DO_JUMP in there to keep her flying, I did the usual ground checks: parameter settings, servo control in stabilize mode, radios, GPS, etc.  Took off in manual mode, checked trims, then swiched to auto mode.  Things appeared to be going well.  There wasn't much wind, but waypoints 2 to 3 marked the downwind leg, while points 4 to 1 (5 is the DO_JUMP) marked the upwind leg across the flying field.  I noticed that throttle dropped to its lowest setting on the upwind leg.  So low and for so long that I was close to taking over in manual.  Then throttle kicked in and the plane continued in the pattern.  Same thing happened on the next upwind pass.  Still, the plane seemed to be doing OK.  I thought I could chance a glance at the laptop and send up a higher cruise speed (airspeed enabled and in "use" mode).  The plane happened to be on the downwind leg.  I heard the motor increase in speed after sending the parameter change.  Good.  Kept looking at the laptop to check airspeed.  Then no motor noise. Uh oh.  Looked for plane.  Nothing.  Concern setting in.  Kept looking. No plane.  Looked at laptop again.  No radio signal.  Did she go down or did she fly away?

    So, something's going on with throttle control.  That's problem number 1.  Fast forwarding to after I found my plane (that's where the drama comes in), I thought I would chance another flight to see if I could figure out what's happening.  I got the following error when attempting to upload new waypoints (problem number 2):




    At this point I decided it's best to quit and fly another day.  Any input on this issues will be greatly appreciated.

    Now for the drama, if you are bored and looking for something to read.

    So, I'm in a state of near panic.  Yes, I'm in the middle of farm country, but dang I hope my plane didn't go down on a road or something and scare anyone.  I'm still thinking it flew off into parts unknown.  I see an airplane silouette far away.  My plane!  I try to take manual control and give stick movements to get orientation.  Nothing.  Try again.  Nothing.  Turns out to be a private plane.  OK, get a grip.  You have GPS!  Look at the map for crying out load.  Hope returns.  The symbol is across the flying field near a break between two crop fields.  One is 3 foot high soybean, the other 7 foot high corn.  Oh man, I hope it's not in the corn.  Even so, just last week someone lost a big canopy in the soybean, surely to get ground up in the fall by an unappreciative farmer.  I decide to walk the perimeter of the soy field hoping for a glance of my white plane.  I know that the corn field is hopeless and pointless to even look in.  Still, I walk along the edge between the soy and corn.  It's about 150 yards.  Nothing.  At this point I'm thinking about the text I'll be sending to my wife.  "Hi Sweetie.  Bummer day at the field today.  Home early.  Love you."  I'm also thinking, "OK, in for a penny, in for a pound.  I'll give the checking account a few months to recover, then I'll start to replace everything."  It always costs me double--what I spend the wife gets to spend.  I'd like to meet the person that wrote that law, but my wife swears it's just the way it is. Who am I do argue?

    At the end of the 150 yard trek, I'm looking for the least crop-damaging path out of the soybean field.  Not going to happen.  I dejectedly turn around and go back the way I came, soy to my left, corn to my right (here I am, stuck in the middle with no plane).  As I approach the area where the GPS says my plane should be, I look even more intently over the soy field.  Suddenly I hear, albeit feintly, "beep."  I freeze.  My heart races.  "Beep."  It's to my right, in the corn.  Oh man, but where!  I walk in maybe two rows and pause.  "Beep" just ahead and to the left.  I stop.  "Beep" straight ahead.  I walk another row.  OMG, there it is!!!  Pitot tube in the mud, corn stalk leaves stuck between wind and fuse, but otherwise completely intact.

    I would usually say "Gee, I think I'll play the lottery today."  But this was so unbelievable that I think I'll choose a good charity and make a donation.  My airplane angel was on my shoulder today.


This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
Benewake LiDAR liked Benewake LiDAR's profile
Apr 12
Gremsy liked Gremsy's profile
Mar 12