I've just released ArduPlane 2.60

The main new features in this release are:

  • wind estimation
  • long term dead reckoning support
  • wheeled takeoff and landing support
  • optional new roll/pitch/yaw controllers from Jon Challinger

For a description of the first 3 new features have a look at my previous post. All of these features have been test flown on my PulseXT 40 and have performed very well.

The new roll/pitch/yaw controllers from Jon can be enabled by building with

 #define APM_CONTROL ENABLED

in your APM_Config.h. If you enable the new controllers then I strongly suggest you read Jons blog post about the new controllers and how to tune them. These controllers are still experimental, but if we get good feedback on them from users we will quite likely adopt them as the standard controllers in a future release.

Other changes in 2.60 include:

  • a new RECEIVER_RSSI_PIN compile time option, to allow you to display receiver RSSI via MAVLink. This should be useful for FPV flying.
  • an important fix from Jason Short for an erase bug in the dataflash. If you use dataflash logs then please erase them after loading this release to ensure the pages are properly initialised.
  • support for the new features in the new MTK GPS firmware
  • updates to the configuration parameters for the Mount code. If you use the mount code, then please check your parameters carefully, as some things have changed.
  • a fix to the JUMP command in missions, which solved a problem where the wrong command could sometimes be run
  • a fix to the initial yaw from AHRS when using a compass
  • new FENCE_ACTION_REPORT value for FENCE_ACTION
  • new "OBC" failsafe code as a compile time option
  • new RST_MISSION_CH option
  • new STICK_MIXING option
  • support for dual stabilisation mounts (eg. one camera and one antenna)
  • removed old CLI switch and dip switch support
  • fixed a derivative filter bug that could have a small affect on AHRS attitude
  • fixed LOITER_TIME to match MAVLink spec (time is in seconds)
  • added FBWB_ELEV_REV option

Happy flying!

Views: 6502

Reply to This

Replies to This Discussion

Hello, can someone shoot me a quick answer if they happen to know.  Does the software still support hooking up 2 current sense boards?  In the manual it shows that A1 and A2 are for volt and current sensing, but it also shows A3 and A4 can be used too.  I do not see the parameters available to set up a second sensor or where it would be displayed.  Any ideas??

If I load V2.6 will I have to redo the level or will it save that for me?

Hi Mike,

yes, you should re-do the level. I should have mentioned that in the release notes, sorry!

Cheers, Tridge

Hi Jonathan,

We don't yet support 2 current sensor boards. I have been meaning to add that, but forgot for this release.

Cheers, Tridge

I usually let Mission Planner do my updates, but under firmware it is only showing v2.5 (i have MP v1.2.6)

How do i maunually install v2.6?

Thank you Andrew! :)

James,

You'll have to use Arduino 1.0.1 to compile it and load it yourself to the APM board.  I just did this for the first time and it wasn't too hard at all.  Just follow the instructions in the Wiki and be sure to go slow the first time.  Make sure you follow the procedures and it should work.  

See here:http://code.google.com/p/ardupilot-mega/wiki/Programming

Oh ok, thanks for the reply!  If you do find the time, it would be a great feature :-)

Thanks again!

Where can I find more information about the "support for the new features in the new MTK GPS firmware" new feature?

 

I bought two current sensor boards before I realized this wasn't implemented yet. So +1, it would be great to monitor both batteries.

Thanks for all the Dev Team's great work.

Hi Andrew,

Thank you very much for the updates.  I gave things a quick look this evening in simulation and had an issue with the joystick.  I'm wondering if MP is not loading the HIL sim version, but it might be a firmware issue.  The joysticks work fine in MP initially, can be calibrated, etc.  However, as soon as you connect to the simulator, the joysticks are not operative any more.  No joystick data from ArduPilot on the sim page in MP, and they are no longer functional on the configuration page in MP.  What makes me not so sure that his is an MP problem is that I was using an earlier version of MP where they worked fine before.  When I loaded the sim firmware, it did note it as version 2.6.

Thanks,
Paul

I will like that feature too.
Thanks for all the work and the new awsome features

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service