Moderator

Arduplane Autoland

I have been trying to get the autoland feature working for a couple of weeks now to no avail? The first time I made a flight plan with several waypoints and then a final LAND command where the plane would reach and then stall, on the second attempt I read the wiki and followed the instructions there, which consisted of using two LAND commands and adding a break alt, radius and cut alt commands, athough in mission planner the colomns are not marked as they are in the wiki? they are just blank boxes... But using the same boxes as in the wiki I filled in the other parameters and started another mission this time the plane would stop at the waypoint before the first land waypoint which was a few hundred meters away, and just drift off without throttle only remaining stabilized until enough airspeed had dropped away and then go into a flat spin. What am I missing?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Moderator

    Ok, I still seem to have trouble with autolanding or even dropping altitude? I tried to drop it into wind over say 500m from 100 dropping by 20m at each waypoint till 40m just to make a low pass.. But by the time it was around 70m it went into a flat spin and I had to switch into manual to recover it.. It seems to hold cut the throttle in order to drop altitude but doesn`t pitch down to keep airspeed, it just uses the elevator to hold a level attitude until all airspeed is gone and forces the aircraft to stall? I have the APM2.5 and an airspeed sensor

  • Developer

    I've been looking at code and I cannot see how it would handle two LAND commands. It seems to work that you set the landing coordinates and altitude where you want to land, and when the plane is within 3m Alt or 2 secs to this location it cuts throttle and makes sure the plane does not roll. The pitch is held positive if you have no airspeed sensor.

  • Confirmed. This is a bug in APM.

  • Hi,

    I just started to learn how to use ArduPilot and the Mission Planner software. I hooked up HIL simulation with x-plane 10 and tried to make a simple mission with auto takeoff and landing. I think I am seeing exactly the same problem as described here. 

    I will attach screenshots of the plan and the actual flight:

    Here is the plan, which tries to mimic the one shown in the wiki.

    3692602488?profile=original

    And here is the actual flight:

    3692602413?profile=originalSome observations from the flight.  The plane takes off and levels, then climbs to 100 meters. Once 100 meters is reached it turns to WP2, then continues to WP3. After WP3 I click a point in the map and say "Fly To Here", which works well. After some loitering I switch to auto, and the plane proceeds to WP4, then to WP5. 

    At WP5 the throttle goes idle and the plane just glides continuing the trajectory from WP4. The screenshot is taken just before crash.

    Based on the documentation I expected the plane to continue to WP6, circle around it down to 45 meters using 17 meter radius, then head to touchdown point (WP7) and cut the throttle at 20m. 

    I have repeated this couple of times, the result is always the same. I am glad that I am using a simulator for learning. 

    Am I doing something wrong, or is this indeed a bug?

  • Someone else posted a video around here somewhere of the exact same problem. Would be great to get this worked out. I'll mention this problem in the "New ArduPlane release coming soon!" thread.

  • Moderator

    O.K so no one has tried the autoland feature with success? Surely someone must have tried it?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
8 hours ago
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…