Hi there, 

I'm new to ArduPilot and a in the process of setting up APM 2.5 on my plane with the latest versions (Arduplane 2.74b and Misson Planner 1.2.62).

I have been following the instructions at http://plane.ardupilot.com/wiki/flying/starting-up-and-calibrating-arduplane/

But when I go into Hardware > Mandatory Hardware > Arduplane Level, the "Calibrate Accel" is greyed out.

I would also like to manually calibrate level as my plane does not sit level on the ground (no wheels and round fuselage) but cannot see the Manual level tickbox or couldn't find it in any of the parameters.

I have tried searching for similar issues and did notice issue #113 (i think) relates to this, is there some workaround meantime? perhaps using the terminal/CLI?

Thanks (and apologies if I have missed anything obvious)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Removing the Mission Planner's manual leveling ability was not an oversight, it appears to have been directed by "Tridge" from the developers group.  Here's his email to Michael Osborne telling him to disable that ability in MP --

    Hi Michael,
    The stable version of APM:Plane has now removed the MANUAL_LEVEL option - it now behaves the same as copter and rover, where you always need to do a manual level, you can't choose to auto-level on each startup.
    Can you remove the MANUAL_LEVEL option in MP?
    There are also quite a few other parameter changes, such as the new TECS parameters, and new attitude controller parameters, plus quite a few removed.
    Cheers, Tridge

    Reply to this email directly or view it on GitHub.P9ZzL2i90nsbAwj4S0BvWzgX-eD5RziZf1ZVdwlXBzsdrxc6d5gN84Dq-l6SOo1q.gif

    They just didn't test this enough to see that it now needs a terminal emulator over telemetry for the many cases where the APM hardware is enclosed inside the airplane and cannot be reached through the USB port.  Let's hope he redirects Michael to solve this problem in MP's terminal acreen.

  • Moderator

    What has happened is that the option to "have to set the level (i.e.keep the plane still and level) on each start-up" has been removed.

    The button requiring the once-off manual levelling is still required and currently is (erroneously) greyed out in MP v1.2.62 and thus can only be done in the CLI.

  • Hi, I am also having this problem.  I have a new, unflown APM2.5 and just loaded 2.74b firmware.  The box is sitting level on my bench but starts up reporting node up of 0.2 units and left roll of 2.2 units.  I've tried a reset to clear any old data but this has no effect.

    Same as you, the hardware level function in Mission Planner is disabled.

    Does anyone out there have any input?

  • Hi guys,


    same problem for me too.

    I tried searching on the forum but the search button does not work...




This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25