Today I had a crash with my x8 which worked fine for at least 20+ flights. After the automatic bungee launch the plane climbed (step but as desired), I then decidedto switch back to fbwa. Then the plane started spining rapidly, and I couldn`t controll the servos at all. Stabilize, fbwa, rtl, auto ... nothing worked!!! If it would have affected only one Servo, the plane should have changed the spin which was not the case too.  At least the motor shut down after switching out of auto!

The plane is fine! After a uncontrolled 150m spin. Turns out that a 3.2kg x8 comes down rather slow when spining...

I looked at the logs and it seems that both servos went out at some point. They worked fine when I recovered and tested the plane minutes later though...

My current guess is that the 5a bec, which supplies the servos, shut down... So I`m going to install another seperate bec for the servos. If somebody has any other ideas, please let me know!

Thx and regards


Views: 222


Reply to This

Replies to This Discussion


What flight controller are you using?

If it is a Pixhawk, did you install the zener diode per the Wiki instructions Link 



Hi Thomas

Thanks for your quick reply!

It`s an APM 2.6 board powered by a 5v 1a BEC for the APM and the 5a BEC of the YBE 70a ESC for the servo side. Servos are Hitec mg65 I think.

Besides, if the controller rebooted because of a voltage problem, shouldn`t there be two seperate logs? 



After another look at the parameters I discovered that the pitch min/max tuning parameters were both set at 30/30 instead of 30/-30 which would explain why the auto modes didn`t work but not why the plane was not managable in manual mode ...

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service