I have assembled my GCS Ardustation, added the Xbees to it and plane and they worked for a short time until building a nice fancy box for the GCS. Upon installing to the box the GCS no longer worked. The unit booted and the display works. The three center row buttons function although the left and right buttons seem to have the same function. I am not finding any info in the assembly site for an explanation of all the buttons or lites. I get a blue signal lock lite a green power lite and a flashing (now)ASC red lite but no telemetry. Does anyone have knowledge of the meaning of the red or ASC which on the board trace goes directly to the Xbee? Although I show signal lock no telemetry anymore. ASC lite did not previously flash. What do you think all? I have reconfigured the Xbees. As an aside the Xbees are marked as DP units but when interrigated by the config tool it sees them as DM units, strange. I am providing as much info as I can so as to make some sense. Just knowing what ASC is an accronym for might help. Thanks guys.

Views: 185

Reply to This

Replies to This Discussion

The red light comes on when my ardustation receives data.
Thank you for the response about the light. When the unit "was working" ie recieving and displaying data I dont remember the lite flashing. Also the light will flash immediatly on startup with either Xbee module whether receiving from plane or not. Since this is true I less suspect the Xbee's are damaged, both at once. When one is installed in the plane I get blue communication light on the station.

I would remove it from the box and give it a good visual inspection. Could something have been shorted or disconected. A solder joint could have cracked from mechanical stress. One of the lights is on all the time. It just means the Xbee is on and not in sleep mode. The other is the RSSI and it indicates a data reception. I am not sure about the colors because mine is custimized. I have the blue as the RSSI and could be different from the stock setup. I have my unit in a custom box with all the switches an leds on a separate board mounted flush with the display.

Keep in mind these general safety tips. Never power up the Xbee without the antenna attached. Its easy to forget even when you know this. Never put in a lipo pack directly under the PCB where it could get punctured by a lead poking through. If you are using RPSMA connector you should tighten its' nut down before screwing down the board. If the holes don't line up then you must fix them(widen the holes). If the board is not aligned and the nut tightened you could put a lot of stress on the Xbee and damage something.



Greg I found the reason for the problem regarding the reception of data.  Was reading another part of the forum about possibly using the computer screen along with the ardustation and suddenly realized I had reconfigured AP to use Jasons GCS. I made the change to the standard GCS and it worked. I am receiving telemetry again. I had made the change from the standard in hopes my box would respond to the buttons on the top row as well as the bottom except for the beep they make. No luck with that! I wish I had not mounted the 3 nonfunctioning buttons. The box would look cleaner. On the stock station the upper left LED is power (green) the bottom right blue (RSSI) and the red (ASC) LED to its left. My red (ASC) flashes constantly even now that it is receiving and displaying data, very annoying. The ASC begins flashing immediatly upon switching it on during boot and before screen display is working. I would say if you have three LEDs and none blink then you have it all together right! I am considering just unsoldering it if I cannot fix it. I believe it is driven by the Xbee. Xbee site not friendly to find info on pins and their functions.

Ok having said all that and now that I have the the AP reporting, the airspeed reports starting at 0 then jumps to the mid 200's in value. Now I don't know how to interpret this, perhaps place a mental decimal point. Reading through the AP code files it mentions including the SPI file if you are using the airspeed sensor which is in the lifraries file . Do you suppose it is automatically included? Also when doing a post flight read in the config tool the airspeed is never over a 1.

I think your ideas on the box installation are excellent. I am using a NMH batt but considering a lipo as I have seen on the web.

Speaking of the web. It would be great to consolidate all the successful troubleshooting solutions and caveots into one easier spot to find them. Maybe I am just too new.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service