Hi there,

I just updated from 1.2.86 to 1.2.88 and it seems they've changed how the ground coverage is calculated. At 60m with my old camera I'd get pretty darn close to 1.9 cm/pixel according to my calcs, the 1.2.86 calcs, and my photos I was getting. The new version suggests the same setup will give me 6.87 cm/pixel and that the area covered by each picture is way larger than it actually is.

I don't know where or how to report errors so I thought I'd bring it up here and see if anyone can suggest what I should do with this information.

Thanks and happy flying!


EDIT: Similarly, does anyone know how to download an older version of MP? I can't seem to find the link to anything other than the "most recent version"

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am having the same problem even with MP 1.2.99.

    I fly the Tetracam ADC Micro for crop NiR NDVI analysis. I used the preconfigured Tetracam ADC Micro that showed up in the camera list, checked all of the specs against the Tetracam website's spec page and they look good. The spec page is the black picture below. The only thing that doesn't match up is the Field of View horizontal and vertical, they are too large almost exactly by the conversion factor of feet to meters (3.28 to 1). This if not noticed will cause you to plan strips too far apart and camera triggers too far apart also. I can make the program behave if I adjust the Focal length again by the conversion factor of feet to meters (3.28 to 1) So, if I multiply the focal length of 8.43mm by 3.28 I get 27.65mm and then my Field of views are correct and the footprints and waypoint generation is correct and all is well...

    I hope all of that makes sense ;-)

    Anyway Michael, is it possable that a conversion was left out of the code or something?

    Thanks for your help.

    In the mean time I will just make my Field of views match the specs given in a FoV calculator I downloaded...




    • Developer

      can you confirm your focal length and check there is no multiplier on that focal length?

      also on the tetracam website it says this


      3.2 Megapixel CMOS sensor (2048 x 1536 pixels)

      • Yes Michael, I actually am a Tetracam dealer (CalUAS) an have a good working relationship with the guys there.

        I went there and asked them that, I actually thought I'd found an error in there spec sheet, like maybe the focal length was really 28.43 instead of 8.43 mm but they confirmed that it really is correct. Steve over there is the one that noticed the numbers were off by what looks to be the exact conversion factor of feet to meters...

        And yes I can select the resolution to be 1024 x 768 or 2048 x 1536 and I've tried both with identical results.

        • Developer

          im still not seeing the issue. I entered a new camera with the 2048x1536 numbers. and they agree to what was on there website?


          and when using the 1024x768 it should be exactly half. which it is.

  • Developer

    try picking another camera, then selecting the original.

    the only difference in newer versions is it trys to remember settings from the last run. which is why I suggest above.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21