Autotune doesn't seem to work

I have done auto-tune in the past, but I'm currently having problems which I can't seem to resolve.

My setup includes a 3DR Pixhawk running ArduCopter firmware 3.3.2   with the default values for the PID.

I've setup Channel 5 to get into Alt-Hold, and channel 7 is set to start auto-tune.  Also re-did the radio calibration several times.

When I fly and follow the procedure, auto-tune doesn't seem to do anything.

To verify that all is set correctly, I connect the Pixhawk to the mission planner on the ground, and do the following to simulate the procedure:

1. Arm

2. Raise throttle to avoid Disarm

3. Enter Alt-Hold

4. Switch to auto-tune

The display does show the auto-tune as starting, so it doesn't seem to be a configuration issue, but still, when in the air, nothing seems to be happening.

I would appreciate any help in resolving this.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • only thing i can think of is that auto tune does initialize in air but does not start because the drone is receiving RC inputs continuously for some reason due to bad calibration or problems with your transmitter. thats the direction i would take. Like the RC stick not fully centred or something. 

    • I have verified that I have no trims, and performed radio calibration to accept the current centers as correct.

      Is there a way to configure the sensitivity, in case the transmitter is not keeping perfect center for some reason?

      Only other option I can see is to use a different transmitter and hope for the best.

      • only input should stop it.  - and deadzone ensures that it does not need to be a "perfect center"

        make us a short log of such attempt:

        1. in stabilize, Arm

        2. fly to 5 meters

        3. Enter Alt-Hold

        4. auto-tune on

        5. no input from you  .. wait 4-5 seconds,

        if no twitching, land, post log

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Oct 22
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Oct 22
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Oct 22
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Oct 22
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…