Autotune Problem

Hi all.  I posted this in the wrong forum yesterday, so I just edited it to post it to the 3.x forum.  I am hoping someone can help me out.  I appreciate any help that you can provide.  My quadcopter flies fine except for the issue noted below.  The problem I have is when I start autotune, everything goes fine until usually a minute or two in.  The quad then pitches or rolls as it normally does in autotune but it doesn't come back to horizontal and just takes off full throttle holding the pitch or roll autotune had the quad perform.  I have been lucky to recover from all of these unexpected maneuvers.  There was one time that the quad did this and flew a good 50 yards away before I was able to get control again.  I just don't know what is wrong with it.  I have never been able to complete an autotune.  It always fails after one of these maneuvers.  I was reading that there are a few things that can cause an autotune to fail.  One is flexible arms on the quad.  I tested mine and they do flex a bit, but I am not sure if it would be enough or even the reason the quad does this in autotune.  The specs for my quad are listed below.  

In stabilize, the quad flies great except when I initiate an oscillation by moving the pitch/roll stick back and forth.  The quad then goes into an oscillation that is almost unrecoverable.  The only way I can recover from it is if I lower the throttle and gently increase it.  If I give it more throttle or adjust throttle to keep the same altitude, the quad will most likely crash.  I tried re-tuning the quad but it does the same thing.

I have completed several planned missions with the quad.  I wanted to complete an autotune before putting my camera gimbal on the quad.  I am uneasy about putting it on because of the oscillations that can be induced and potentially causing a crash.  

My son took a video of the problem but he's only 5 so the video isn't all that great and didn't capture the problem the second time it happened.  You will see the quad take off to the left during auto tune but I recover quickly in the video.  

http://youtu.be/c3TMNY-Hmgs?list=UUx4C9BKl4FobHFG-ln4v-yQ

Hobbyking AQ-600 frame

Sunnysky X2216 1100KV motors

Turnigy Plush 30A ESC's

10x4.7 props

APM 2.5 with external compass

3DR uBlox GPS with compass

Arducopter firmware version 3.1.5

5000mAh 3S battery

2014-08-30 11-03-13.log

IMG_20140821_124722203_HDR (Medium).jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Zach,

    I will definitely let you know if I find out what the problem with my quad is. I'm just not sure what else to try. I tried looking at my logs, but interpreting them isn't the easiest thing to do. I will have to go back and see if ATDE data is included in my logs. If not, then I should probably go do anther auto tune flight with that enabled and upload it to my post. I'll try and get another video also.
    • Hi Arion,

      I had some luck yesterday with my quad. I noticed the quad would oscillate around the 1-2 axis fairly quickly, probably just under 10 Hz in a pretty unstable way. I also noticed motor (2) on my quad was angled slightly towards the center of the quad. 

      I loosened all of the arms and re-torqued the bolts while the quad was level which seemed to slightly lessen the oscillations, but the biggest difference was made when I calibrated the ESC's. Video demo here: https://www.youtube.com/watch?v=gYoknRObfOg. I would suggest giving this a try. After calibration my oscillations were gone but the quad was still 'twitchy'. No where near as bad as before and seemed to be working at a level that would allow autotune... so I tried it. Success!

      After autotune the quad flew rock solid for 3 batteries. (45 minutes).

      I'd give the ESC calibration a shot if you haven't already.

      Zach

      • Zach,

        Thank you so much man.  The ESC calibration worked!  I had zero problems after I did that.  I could not induce an oscillation when I tried stabilize.  I then tried autotune and it completed with no problems!  My quad flies perfect now.  Thanks again man.

        Arion

  • Hi Arion -

    I had a look at your video. It looks similar to what I experienced today. Let me know if you figure out what is happening and I'll do the same. 

    Another note I remember now after reading your post I only put 1 out of the 4 screws on for each of the quad legs (F450 frame) I have so it's possible there was some flex there. I could see that resulting in the instabilities I mentioned in my post but have a hard time believing it could cause the quad to power up and blast off to the left (mine was left too...) the way I saw today and you show here.

    Zach

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
yesterday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
yesterday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
yesterday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…