Bad compass health, No RC receiver

Hi guys, took my arduplane for a flight the other day (EPP FPV) and when I went to look at the telemetry after my flight, I was confronted with the warnings NO RC Receiver and BAD COMPASS Health. I was flying in manual mode, so i definitely had the RC receiver working, and Im not sure about the bad compass health, as this is a new warning, on all my previous flights my compass health has been fine? 

Im flying 2.74 on an APM 2.5

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • hi guys  i have the same issue i try internal and external compass and still i have the same warning ..

    has anyone solved this yet?

    • I cured it by improving the power supply to the APM. I originally used a 5v regulated power supply when I got all these GPS/compass health messages. The Vcc was fluctuating a fair bit and getting close to the limits so I changed the power supply to a chinese APM power module. (I tried 4 before I found a good one, but that's another story). Now Vcc is much more stable and GPS/compass warnings have never returned without good reason.

  • I have apm 2.5 with an external compass which I have been using in a quad with great success. I just transfered it into an X8 Skywalker and loaded 3.1 and immediately had all kinds of trouble with the compass not calibrating, very slow response in MP HUD, and the "bad compass health. Tried swapping components around but made no difference. Final answer was to load 2.74 and all the problems went away.

    • I spoke too soon. Bad compass health is back. I have swapped compasses to no avail. Has anyone solved this issue yet?

    • T3

      Loading 3.1 would mean loading a multicopter firmware in an airplane so it definitely wouldn't work at all. 2.74 is one of the possible firmwares but they're only up to 3.02 right now.

      • Oops, 3.01?

  • Yep, got the bad compass message to, even calibrating is not working well here, always get the message not enoug bla bla bla stuff, plane is flying well.

  • Same here, with AC:3.1.0.... (NO RC Receiver and BAD COMPASS Health)

    Menno

  • I was flying 2.71 for some time and never had a problem – all flight modes and missions fly well. I upgraded to 2.76 and now get BAD COMPASS HEALTH. This is a custom lightweight airplane with no ailerons and no airspeed sensor. APM2 and external ublox GPS

    It’s either a bug or maybe the detection is just way too sensitive.

    Does it change any internal logic when this message is triggered? Is it safe to fly Auto Missions with this version? I don’t want to have a flyaway!

    .

  • Updated to ArduPlane 2.7.6 and get BAD COMPASS HEALTH messages randomly during flight.  It does seem to be better for a while after a compass calibration.

    I tried different APM2.5 boards, exactly the same result.  The problem is affecting auto modes and not performing well in RTL, Auto and Loiter as it did before. Any ideas? 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…