Bad Gyro Health Pre-Arm Check

I have cleared my EEPROM and am trying to do a clean update to ArduCopter 3.1.2 for my Quad.  I am using the wizard to go through the initial setup process.  Everytime I get to the Accel Calibration, I start to have problems...

Whenever I am asked to put the APM on its left side, as I start to turn the quad, I get a "Bad Gyro Health" announcement through Mission Planner (using latest and greatest MP build).  I am able to complete the Accel Calibration, but when I get to the pre-arm check step, I am unable to arm due to the Bad Gyro Health.  

After I complete the wizard, I have tried to re-do the accel calibration individually but I get the same response.  When I am prompted to put APM on left side, I get the bad gyro health message immediately.

Also, when I look at the HUD display it has a warning saying "Bad Gyro Health".

I have an APM 2.5 w/ internal compass and external GPS.

Any help on what could be causing this problem and possible solutions would be much appreciated.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This sucks.. I'm getting the same thing.. It was working fine, had Firmware 2.74 on it and running MP 1.2.29.. Decided to upgrade to MP 1.3.6 and 3.0.3 today and now it says "bad gyro health"..  If oyu let it sit for an hour it then works, but if you unplug it and then power up again, I get "bad gyro health" and have to wait another hour or so..  (it could be 30 minutes, was so long I didn't keep my eye on it.  I tried going back to 2.74 and 1.2.29 with no luck..

    Odd thing is, 1.3.6 change log says it fixes issues with "bad gyro health"!! lol    So is mine toast now?

  • I just installed AC 3.1.4 on my jDrones APM 2.5. Calibrated accelerometer and compass without any issues. But it shows the Bad gyro health on the HUD. I measured the I2C port, its giving out 4.4V. The HUD is working fine, it just shows the Error. I can't find the regulator on my jDrones board, does anyone know where it is? 

    Also I installed AC 3.0.1, and the Bad gyro health error disappeared. Can I still fly using the board? What should I be careful about?

    • Hey Arunabha,

      there is an image on this link

      which shows you where the regulator is.

      If it still ok to fly with your board, I cant tell ya, but I think the regulator is blown if the I2C is showing 4.4V instead 3.3V. For my case, I replaced the original regulator, explanation above. And now I haven't a problem with this error message.



    • I had the same problem. I use now 3.0.1 - everything 100% OK

  • Max - Sorry to hear about your issue with the brand new APM. I got my APM2.5 a year or so ago directly from 3DR Robotics. I didnt have a Bad Gyro Health issue until updating to 3.1.2. I think that the blown regulator did not cause any problems for previous versions of Ardu Copter (assuming that is the problem).

    What exactly does the "Bad Gyro Health" error mean? Is there a specific variable that is causing this error to occur? Can you still fly with it in Stabilize mode with a radio transmitter? If I turn off pre-arm checks then this error shouldnt have any issues.

    When I reboot Mission Planner, it seems as if the HUD is displaying my quad properly. Yaw, Pitch, and Roll display when I pick up the quad and move in various directions, position feedback looks acceptable to me.

    Any other recommendations would be much appreciated. Thanks!
    • Rack me up as another Bad Gyro...Thing is, this APM worked fine when I put it in the drawer 6 months ago, and now I get the message. The additional issue is that my HUD in MP swims - rolling around in a "figure of 8", and the compass going right round the dial. Both Acc and compass calibrations went ok.

      Problem exists on 3.1.2 and 3.1.3

      • Try firmware 3.0.x - mine is flying perfectly

        • Where can I find the last 3.0.x version? I'm trying to trawl through, but it's a bit of a nightmare to find the last stable 3.0.x release...

          • you can find the version in each git-version.txt

            • @Euan Ramsay

              I solved my problem...

              One of the capacitor wasn't there anymore, I have no idea why but i replaced it with a 10nF capacitor..I'm guessing they're function is to damp the signal from the 3.3V regulator. So doesn't matter what you use....

              I also changed the 3.3V regulator , because I've heard that he's blown when he 'sees' more than 3.3V.

              For APM2.5.2 : TPS79133DBVR

              This is the original regulator but I had an Reg 113 3.3V at home so I solder that onto the Autopilot.

              On the board is a jumper from the right to the middle 'feet' of the regulator (pre-installed), the Reg 113 3.3V regulator needs a jumper from the left to the right 'feet', to have the same characteristics as the original.

              So for me it wasn't a software was a hardware it works fine..

              At first I also had the message 'Bad Gyro Health' and the HUD swims and roll around.

              But not anymore.



This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21