Bixler dives on RTL...

Hi, I recently had my maiden flight with a Bixler 2, which actually resulted in a crash (fortunately not too severe... )

My Bixler is fitted with a nice APM2, arduplane 2.61 with Bixler default params loaded, airspeed sensor, and a very lightweight 1.8A battery in the nose of the beast. The nice bixler flaps have also been configured on channel 5 as Auto Flaps.

After a manual launch, I realised I had 2 channels inverted (Rudder and Aileron I think), which I though I had checked of course, but apparently not. That was quickly fixed at the 9x level.

Second manual launch, I quickly shifted to Stabilize mode, which was ok, although the plane showed a small tendency to go down and right. After checking on the ground that my control surfaces were in fact ok, I decided to manually apply a bit of flaps... probably a strange way to correct the plane up/down behavior but I read that a bit of flap makes the plane go up... Which seemed to work ok for nose diving, although still the same for going right very slightly..

Anyway, given all these parameters, I still decided to test RTL, which ended up in a big turn on the right, and a quick dive... fortunately I could quickly switch back to stabilize and recover.

My crash was just after an ultimate launch, mistakenly launching the plane in RTL mode, which obviously didn't go very far in the current situation :-\

Anyway, few interrogations here:

  • is there a specific APM parameter I should preferably look at in order to fix the nose diving when in RTL
  • is there a possibility that the flaps config be reverse at the APM level ? I have also assigned flaps on a channel of my 9x (Pit Trim), and i can only say that turning the button right will make the flaps go down, left up.

I have to say that I didn't measure exactly the final COG of my bixler, which seemed approx in the right spot; I didn't worry too much about that aspect because I have very little equipement in the plane, and a light battery... so I assumed that wasn't the reason why I would be nose heavy during flight.

Thanks in advance for any expert advice on that. Let me know if the log file could potentially help, although I noticed through looking at the KML that it only shows a very small portion of the flight... (maybe only the last launch..)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi all, I finally found time to get back to flying, and succeeded this time, following most of your advice:

    • Disabled entirely the flaps, to early for that..
    • Setting ALT_CTRL_ALG to 1, in order to have the APM not controling the pitch and throttle using the airspeed device
    • Enabling the airspeed but not making use of it (2 different params)
    • Moving my 1800 battery in the rear part of the inside space, for the center of gravity to move backward

    After just a bit of trimming, the plane was stable enough to test RTL, which unfortunately had the effect of going the wrong way, away from me... However, it seemed to do it without diving like last time :-) 

    I suspected a wrong GPS initial position (?), so I landed and started again from scratch. And to my great surprise, another RTL made the Bixler finally come back to daddy and circle (large) around me :-) :-) 

    So many thanks to you all for the great advices!

    In a second step, I also tested my first auto mission, from a square of 4 points of various altitude, and that also worked like a charm. A great WE :-) :-) :-) 

    Next step, make use of the airspeed...

    Happy flying all!

  • Ok guys,
    I found the problem.... The problem was Pitch_Comp I changed it to 2.040 from the original 2.000 and it flies like a dream now on Auto...
    • Same problem here...! Mine flies like a charm in manual, it also flies well in stabilize, but wean i hit rtl, it turns around, travel a few meters,and then it turns left or right (cant remember)  and dives like a rock... i must fast switch manual to recover...

      Any Help?

  • 100KM

    Hi,

    Keep things simple and follow the wiki step by step and it should be OK. Disable the air speed sensor for the time being, It just complicating things. Make sure you check the control surface movement is correct in manual and stabilized mode. Trim you plane for straight and level at cruise speed in manual mode. Switch to stabilized mode and check if it will return to neutral once you release the control stick. Then switch to fly by wire_A, move the aeleron all the way to one site and hold it there, observe if the plane bank at about 45 degree and hold altitude, adjust the Pitch Comp in PID accordingly if it gain or loss altitude.

    Now that you have satisfied with the turning, make sure you set your home location and hold default altitude box check, your bixler should return to home location and circle there waiting for further command from you. Well, at least my bixler will......

  • Thanks James,
    I like your setup with the flaps, at the moment I have mine configured to a knob on the radio, bypassing the apm. I like this because I can do fine adjustments when flying fpv and using the minimosd to see I fly optimum in order to get long flights.

    I do think the diving problem is because of a bad level seting.. I need to lift the plane more when calibrating using the manual procedure. Think this will fix Manu's problem as well.

    Manu, aslo make sure that in the MP there is a tick for using absolute alt. Dont tick this unless you know what you are doing... Put a good default hight of at least 50m for the begining as this is the hight that RTL will use
  • T3

    Hi Jo, hi Manu,

    Ill try to post some steps that helped me with bixler 2 setup you can see the results here .

    1. calibrate radio be carefull the upper servo end of flaps channel should be equal to zero flap! fix that by adjusting the servo horns.  At the end of calibration, move the flaps to the upper end NOT to the middle . Select your gear (mag, airspeed, voltage sensor)

    2. go to compare parametres and load the bixler params,  select everything that messes with navigation and stabilization! dont select rc related values (rc min max, trim , Telemetry rates, battery etc)

    3. go to arduplane params Tab on MP. and select rc channel (your flaps) to flaps auto (function 3)

    4. go to parametres list and find flaps speed- flaps percentage 1&2.  choose speeds near the stall speed 6-7m/s and no more then 27% movement. flaps on bixler are  very very sensitive

    5. go to leveling tab.   carefully tape your bixler on desk or something with the wing having 0 to +1 degree incidence angle (carefull its not 0 when you place it down on belly), use a leveler for roll (i used one on each wing)  press manual level 

    ready to rock!! 

  • Developer

    Hi Manu,

    The most common reason for descending in auto flight when you have an airspeed sensor enabled is that the target airspeed (TRIM_ARSPD_CM) is not being reached. In that case the APM will put the nose down in order to try to gain speed.

    If you have a tlog then we could diagnose it from that.

    If you are not experienced with tuning an aircraft with an airspeed sensor then you might like to set ALT_CTRL_ALG to 1. That will tell the APM to control pitch and throttle with the non-airspeed algorithm. That is a bit simpler to tune.

    I'd also suggest that you leave experimenting with flaps until you have the plane well tuned. You shouldn't really need them with a slow flying aircraft like the Bixler.

    Cheers, Tridge

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
20 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
20 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…