I had an unplanned landing tonight (otherwise know as a crash). No real damage to speak of, Broke my Pan mount for my FPV camera. The video pretty much says it all thanks to the MinimOSD.

I was gathering some information on Max Climb pitch/throttle and sink rate/pitch while maintaining cruise speed while flying in FBW-A mode. Unfortunately I let my airspeed drop a bit too low and stalled the plane low to the ground.

After the crash I reviewed the video footage, and then the telemetry log. I got the information I was looking for from the flight and went to change the appropriate paramters........that's when I found out I couldn't access the parameters.....hmmm I'm getting telemetry.....the HUD responds appropriately to roll and pitch...but I can't read the parameters.

 

So my question is: Can an impact such as this cause corruption of the firmware loaded on the APM? If so how would you be able to tell if it was something less obvious.

 

I haven't had an opportunity yet to try reloading the firmware, but I did extract the parameter file from the telemetry log. So at least I have backup.

Is there any procedure I should follow to reload the firmware and parameters?

I attached the extracted parameter file as well as the tlog from this flight for those who are interested.

 

Regards,

Nathaniel ~KD2DEY

Views: 406

Attachments:

Reply to This

Replies to This Discussion

I had a chance last night to examine the damage caused by the crash, and to look into the issues I was experiencing with the APM/Mission Planner. The results of that examination showed that I am truly lucky!

The fuselage on a Super Sky Surfer is assembled from two interlocking halves (port and starboard). If you want to buy a SSS, I would recommend buying the kit; the glue used in the ARF looks like an aliphatic resin, like wood glue. Not well suited to the task. It would also allow the builder to move the servos for the tail surfaces back to the rear, closer to the control surfaces for a more positive control setup.

Anyway the only damage to the plane itself was caused by my 13x8 prop slicing into the tail boom when the boom flexed upward, and the motor sagged downward. The damage was really minor and I applied epoxy to the fuselage joint, then made a patch of fiberglass cloth to strengthen the area cut by the prop. The only other damage was to the pan servo/mount connection. I epoxied the servo horn to the output shaft (don't worry I made sure the servo/shaft area was free of epoxy!) and that was all the damage!

As for the APM, all the hardware was checked and found to be working properly. I still couldn't retrieve the parameters from the APM using the Mission Planner, yet everything seemed to work fine. I put the plane in Stabilize and moved it around while watching the HUD in the MP and all was well! The GPS worked, the Telemetry worked, the airspeed OK, battery voltage/current OK, RSSI OK, MinimOSD OK......everything worked fine. Still I couldn't retrieve my parameters using the MP, so I reloaded the firmware and uploaded an extracted copy of my parameters. Bingo, now I can read my parameters from the MP!

I don't know what would cause the parameters to be unreadable by the MP but it appears that all is well now......I hope.

If anyone has any theories or suggestions of things I should check before my next flight...I'm patiently waiting with eager anticipation!

Regards,

Nathaniel ~KD2DEY

BTW I must reiterate that this was the result of nothing more than pilot error, not anything related to the APM or firmware!

Hi,

I'm not aware of any physical impact that can cause a parameter list to disappear. Well if a power wire fell off, or maybe the battery was almost empty and the blocking of the propeller biting the tail caused it to brown out, then an EEPROM corruption could happen (but should not). Anyway, if you observe this again, try to start up APM while connected to a terminal emulator program like HyperTerminal or TeraTerm. The bootup diagnostics messages will show there.

How to you connect in MP without loading the parameter list? Even if your plane is x km out, at the other end of a radio link too bad to load the parameters, it wants just insists on loading them before even wanting to show you where the plane is. Did you use the secret CTRL-T connect?

BTW, MAVProxy can do both of the above - show startup messages and separate the issues of connecting and loading parameters.

I used to have an EasyStar, a (much) smaller plane of the same layout as yours. At one point I cut off the whole tail boom and cut two lengthwise grooves at the rear bottom of the fuselage. Inside the grooves I glued two balsa sticks running parallel as the new tail booms, and added a balsa/Depron tail in the same measurements as the original, and like you I moved the servos closer to the tail (all the way). Now there was space for a much larger propeller, and I was able to triple the plane's endurance!

Regards

Soren

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service