Can anyone help identify why Auto and RTL both failed?

Hi guys,

I need to use my Y6 (APM 2.6; AC 3.1.5) for surveying and need to be able to automate missions, but today my auto mission didn't complete and RTL failed - it was as though the flight mode changed to loiter and ignored RTL signals. I've spent several hours trying to work out what went wrong, but still can't get to the bottom of the multiple failures so I'd really appreciate some input.

I've previously flown successful test missions in Auto mode, which were also designed in MP (V1.3.10) using the Survey(grid) tool. My WP file is attached; I started with a takeoff WP then climbed to the target altitude. WP 2 and 3 should have adjusted the the flight speed and camera triggering distance, and then it should have headed for WP 4. Instead, it just sat at the target altitude above WP1 (as though in loiter). After a few minutes, when it became clear that the copter wasn't going to complete the mission, I tried to initiate RTL (firstly via Ch. 5, then by a Ch. 7 override), but had no effect on the copter so I switched to loiter and landed.

I've got two questions:

(1) Why did the auto mission fail?

(2) Why were the multiple RTL commands ignored?

(I tested the RTL via Ch. 7 a few days ago which worked fine. Subsequent testing shows RTL commands sent from the Tx are received the APM and displayed on the GCS. I thought the most likely explanation was GPS failure had terminated the mission and prevented the RTL, but the copter held position for ~4 minutes in light winds, the sat count was 8-10 and the GPS hdop was <1.80 throughout the entire flight. I don't see why it should matter, but is was ~36 degrees C, and over the coarse of the flight there was ~10 m barro drift.) Reviewing the log (attached) shows the correct flight modes were selected.)

Any guesses? 

 

2014-09-23 14-57-12.log

WP.txt

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have been having the exact same problem.  Thank you for posting the workaround.  

  • You mentioned 10m baro drift. That seems like a lot. Did you check what your altitude was when it was loitering instead of rtl? Also check the log for Ntun DPosX and DPosY to see if it was trying to return to the home coordinates.

    • @John. I'm afraid I didn't check the that as I was focusing on the other things going awry.

      I've just upgraded to AC 3.2_rc10 (beta), and had a couple of flights without observing this - I'll be keeping an eye on it though. Cheers

  • I just found a nearly identical problem reported on the ArduPilot forum in June; narrowing down the problem to a bug with the ‘DO_CHANGE_SPEED’ command.

    From the information on GitHub (#766) and a note on the Wiki, I think the issue might be cause by using the latest MP (v3.1.10) to export commands to an older version of AC (v3.1.5).

    It seems AC 3.2 has been modified to use the second parameter field as the new speed value, whereas AC 3.1.5 uses the first parameter field, which is now set to 0 by MP 3.1.10. This would explain the observed problematic behaviours, so tomorrow I’ll try switching the values in the first and second parameter fields and see if this resolves this issue.  

    • That temporary workaround resolved the problem, which won't be present in AC 3.2.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…