Can not calibrate transmitter for Pixhawk

I have Taranis transmitter. I am using the receiver that came with the Taranis witch is a Frsky X8R. I have tried to connect it to my my pixhawk using a PPM encoder I bought from 3dr and also using the "smart port". The receiver gets power and connects to my radio but I can not do the radio calibration mission planer. the bars on my computer don't change when I move the sticks. I am trying to do this on a 3dr y6 that I built form a kit. This is my first multi rotor so I may just be making a simple mistake.  

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thank you so much for all the help.

    I finally got it to work.

    • Please can you say how you fix, i have exactly the same issue...

      • The fix with the Taranis?

        I finally ended up just manually programing it. 

        • BUt its work for you only conecting ppm encoder to the x8R to the Sbus? or you connect all channles?

          • I did not use the ppm encoder at all. I just plugged a servo cable into the sbus on x8r and into the rc port on the pixhawk .  

            • I screwed up  writing that down the first time 

              • For mi dosnt work only conecting de ppm to the sbus... how u did it?!

                • I'm not quite sure what you mean

  • Yes

    Image from the FrSky site


    • thanks.

      I tried connecting the pixhawk to SBUS it got power and connected to my radio but I was still unable to do the radio calibration.  If I turn the radio off during the calibration all of the bars go down but moving the stick on the radio do nothing. 

      Could it be a problem with the radio? Its always saying telemetry lost telemetry recovered. Have gotten it to work with a little fixed wing rc plane.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21