I'm using Windows7/32

I used the instructions found at:

http://ardupilot.org/dev/docs/building-px4-with-make.html

I downloaded the PX4 toolchain.exe file and installed it.

Then, in "All Programs" I chose 

"PX4 Software Download", but got a bunch of errors.  So, I went to GitHub and downloaded

ardupilot-master     

I changed the name to "ardupilot" and copied that into 

/c/users/<my name>/"My Documents"/GitHub/

so now, I have the folder

/c/users/<my name>/"My Documents"/GitHub/aurdupilot

There are a lot of other files and folders in that directory, one of which is 'ArduCopter'

I then went back to All Programs and navigated to PX4 Toolchain.  That gave me a command-line window.  I navigated to 

/c/users/<my name>/"My Documents"/GitHub/ardupilot/ArduCopter

And, as specified, issued the command:

"make px4-v2"

I get the error message:

CANNOT DETERMINE SKETCHBOOK LOCATION.  Specify on the command line with SKETCHBOOK=<path>.

I had no "Sketchbook" (I don't know what a 'sketchbook is') , so I created a subdirectory off the root (C:\PX4) and typed in 

SKETCHBOOK=/c/PX4     but I got the same error.  So I also tried

SKETCHBOOK=/c/PX4/    and

SKETCHBOOK=c/PX4      and

SKETCHBOOK=/c/users/<my name>/"My Documents"/GitHub/ardupilot/ArduCopter   and

SKETCHBOOK=/c/users/<my name>/"My Documents"/GitHub/ardupilot/ArduCopter/

But no matter what I type in for the path, I get the same error.  What is wrong with my setup?

Also, when I use the 

PX4 Software downloader, why do I get only errors?

Views: 12

Reply to This

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service