Can't connect to APM2.5 through USB Mavlink

Hi All,

I have the APM2.5 board with the power module and GPS connected. I am awaiting delivery of my telemetry system. I have Mission Planner 1.2.74 mav 1.0 installed.

I followed the instructions to install the firmware (ArduCopter V3.0.1 Quad) onto the APM and this is fine. Once the firmware was installed I tried to connect to the APM through USB. The connection times out and the error message says "only 1 heartbeat received". Please see the image for details of the error.

I have tried a few things to solve the problem after reading some other posts with similar issues but nothing works. I have tried:

1. Uninstalled the driver from the COM port and reinstalled

2. Used different USB ports

3. Used a different computer

4. Connected a battery to provide power (in case of brownout)

5. Changed USB cable

6. I have checked the COM port selected is correct and used the 115200 baud rate.

When I go into terminal and connect to APM it tells me:

load_all took 1848us

Arducopter V3.0.1]

Arducopter V3.0.1]

Arducopter V3.0.1]

Arducopter V3.0.1] ?

Commands:

logs

setup

test

reboot

help

Arducopter V3.0.1]

When I type reboot I have a few system stats and then the line:

3Calibrating barometer Q///+?PANIC: AP_Baro::read unsuccessful for more than 500ms in AP_Baro::calibrate [1]

Any help will be much appreciated. Pulling my hair out at the minute!!

C

ExceptionDetails.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi!

    I notice two differents type of GCS connection errors

    "only 1 heartbeat received" => i had this error when parameters saved on APM no fit with hardware config or short circuit /other hardware problem......In first time, the board seem to be dead, impossible to connect it to the GCS

    So just let it off some time (10 min), and it will be ok again , i think there is like a fuse for hardware security.

     

    "No heartbeat packet received"=> i had this error when connecting with wrong GCS version, wrong parameters, USB/telemetry link error/ drivers etc.....soft error.

    Are you ok with this!?

  • flash your atmega32u2 firmware with bootloader i attached. :)

    ArduPPM_v2.3.16_with DFU_Bootloader.hex

    https://storage.ning.com/topology/rest/1.0/file/get/3692896152?profile=original
  • I fixed my issue on 1 PC by uninstalling MP plus the windows driver packages.  Then I put 1.2.72 on, this version installs 2 drivers.  This connected !  So, there is definitely something going on in software / driver land.  It's late-ish for me now so I will call it an evening.

    My next try might be to update sequentially from 1.2.72 to the latest to see where it breaks, the clean up, go backwards and try it again without installing the drivers to see which part breaks it.  But maybe I'll let the real windows software guys step in here, I'm more of a network guy...  :-)

    I found all MP versions available for download here.... in case anyone wants to go back to the future.

    http://firmware.diydrones.com/Tools/MissionPlanner/

  • Dear Everyone,

    I have the same problem; I try on 2 different PC (32 bit Windows 7 Pro and 2nd PC 64bit Windows 7 Pro).

    The ver 1.2.85 Mission Planner installed on both PC; one PC with 64bit version - only can connect twice so far - other time failed. Run on different "compatibility" on Windows 7 options also does not help.

    Please see the attach error.

    Then I use the older version 1.2.62 and 1.2.54 - this work fine. On both PC. Software updates on the APM 2.5.2 to 3.01 went successful and other function/test work fine.

    Re-install software ver 1.2.85 does not work; even do an upgrade from ver 1.2.62.

    Attempt to download ver 1.2.84 - but can not find this yet on the NET. There are some other view on this - check on the NET.

    Is this because of the APM 2.5.2 compatibility issues?

    Hope this add the info on the issues.

    Mavlink Error.png

  • Hmm, same problem on a APM 2 over USB.  Tested on 2 PC's, 2 USB cables, same symptoms...

    PC1

    Windows 7 x64

    APM / mission planner new install of 1.2.85

    APM2 with external 3DR GPS, FW 3.0.1

    USB goes to COM3 @ 115200 (detects APM board)

    MAVlink times out, but I could reprogram 3.0.1

    Terminal works fine, does point out no dataflash inserted

    PC2

    Windows 7 x64

    APM / mission planner upgrade install of 1.2.85

    APM2 with external 3DR GPS, FW 3.0.1

    USB goes to COM7 @ 115200 (detects APM board)

    MAVlink times out

    Terminal works fine, does point out no dataflash inserted

    I've not flown on 3.x yet, had flight time on 2.x without issues.

  • 3D Robotics

    Please contact customer support from the store you bought it from. If that's 3DR, send the message to help@3drobotics.com

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Saturday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…