[Solved] Can't download my logs from mission planner - APM2 (Grrrr!!)

I've been trying everything I can to get the logs off my APM2. I erased the logs with the Logs > Erase command in the CLI. Flew for 3 minutes or so, connect again and then when I go to the terminal tab of Mission Planner 1.1.40, I click Log Download I get this screen:

It shows no logs to download which clearly there are (see last image). It then starts showing the text as above by itself and the amount "Done" increases incrementally for ever if I let it. it got to 27000+ yesterday after about 45 minutes!!

The terminal screen shows this:

If I Type "logs" in the CLI I get this:

And if I type "dump -1"

it dumps the logs but to where, how can I view them or save them?

Can someone please tell me WTH is going on?

Views: 3932

Reply to This

Replies to This Discussion

When you reset the board in the Terminal, does it say "No dataflash Inserted", as below? If so, that means that your dataflash card isn't pushed in all the way. 

No, I get no such message from board reset.

I get this:

It looks like your logs are working fine but for some reason the MP log parser didn't send the right commands and let the APM leave CLI mode. But it works fine on my boards. Can you try again? 

Have tried 20+ times since last reply. Also did full eeprom erase and reload of firmware.

Now get this on terminal screen and no response from mission planner:

Done open 1 1
Request stream MAV_DATA_STREAM_EXTENDED_STATUS at 1 hz : currently 0
Request stream MAV_DATA_STREAM_POSITION at 3 hz : currently 0
Request stream MAV_DATA_STREAM_EXTRA1 at 10 hz : currently 0
Request stream MAV_DATA_STREAM_EXTRA2 at 10 hz : currently 0
Request stream MAV_DATA_STREAM_RAW_SENSORS at 3 hz : currently 0
Request stream MAV_DATA_STREAM_RC_CHANNELS at 3 hz : currently 0

Try a different PC/USB cable. This seems to be unique to your setup.

Using the cable that came with APM2, will try a different one now (all other MP functions work fine)

Does the Terminal otherwise work normally? (it should take you automatically to the CLI prompt). 

This issue happen to me as weel. I can dump the log in CLI, but there is no way to save it.

Any solution?

Terminal otherwise works normally, just booting up my laptop to try on that

Exactly the same on different PC with different cable (Also Win XP)

Managed to save the log by dumping then Ctrl + page up to select all, paste into Notepad (or any text editor), save as filexxx.log.

Cannot get Mission Planner to download the logs AT ALL, with 2 different PC's and different USB cables!!

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service