Can't manually override loiter movements.

I'm working on a small copter, and think I changed a setting I shouldn't have.. Or maybe something else is going on...

I can't overcome loiter drift...  I'm hovering in my back yard w/ not great satellite reception, so the copter wants to drift all over.  On a different copter, I can always fight the loiter movement. But, I just built a small 250 size quad w/ an auav-x2 flight controller, and I cannot manually override the loiter movements..  If the copter is moving forward, and I pull the stick full back, so it should pitch back and fly backwards towards me, it only slows the forward flight.  If I switch to alt-hold or another mode, I can take control as usual. 

Does anyone know what setting controls how much manual input I have over loiter mode?  Or, if something else might be wrong? 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    Loiter is setup to be quite tame compared to alt.hold
    • Well, that's the value I increased earlier, before I noticed this issue.   I'm thinking that setting is how fast it automatically moves itself.. not the level of manual control.. (I don't know, though).
      So, I decreased that setting, and it didn't make much of a difference. 

      I had also lowered the rc feel, which I increased again, and it hasn't made a difference either. 

      • WPNAV_SPEED is for AUTO.

        How much did you increase WPNAV_LOIT_SPEED?  It's in cm/s.

        • I changed all four loit settings, initially in an attempt to speed up loiter mode.   Then I changed a couple again.. 
          I unfortunately don't have a backup... This is pretty much the initial configuration of it. 

          Here are all my WPNAV_ settings.


          I guess it's safe to assume I caused this issue by playing w/ the settings, and I should reset it all to default, and selectively copy over the settings I want to keep. 
          Or, is there a list of default settings somewhere?

This reply was deleted.