I have an mRo (mRobotics) pixhawk that I’ve setup but cannot get SBUS working with my frsky X8R and wanted to see if I can solicit some ideas.

Here’s what I’ve tried

Can successfully bind X8R to Taranis and confirm I can get telemetry back from RX

RX gets power from RC input on mRo pixhawk

Plug in X8R SBUS to RC of mRo PIxhawk and it doesn’t recognize any channels

Tried upgrading to latest arducopter firmware still nothing, tried PX4 stack and same problem

Tried Mode 1 and Mode 5 (D8 and D16) still no luck

Tried same as above with an LR9 and used SBUS port same thing, doesn’t recognize

Tried with a D4R-II on mRo Pixhawk and it works just fine with SBUS. (odd)

Tried the X8R on a 3DR Pixhawk with same setup and worked just fine (confirms the X8R SBUS works)

Strange.  The receivers I know work and can confirm they bind.  Why I’m scratching my head is that the D4R-II works with the mRo pixhawk and the X8R that doesn’t work on the mRo Pixhawk works on a 3DR pixhawk I have. 

I’m out of ideas.  Anyone have any other thoughts or insights?  Thanks in advance!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • That does seem strange. Since the receiver has been bound to the X8R, have you connected a servo(s) to determine if the signal is actual going to the AUX channels on the rx and outputs on the Pixhawk?

    What about channel assignments on the Taranis? 

This reply was deleted.


Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18