Cannot install 3.2, installation fails while reading hex

I have never been able to flash new firmware. Now that 3.2 is out I really want the new position hold mode. When I go to install firmware in mission planner I select 3.2. It goes through detecting board version, then reading hex. The bar starts to fill up and goes till about under the 75% point, then it stops and flashes up an error box "communication error- no connection". My cable and everything is fine. I have been using the same cable to monitor telemetry and program my apm for months without issue. What should I do?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • How are you powering the board? I have had problems with a laptop not supplying enough power through the USB port. Also just for the upgrade try unplugging things from the board and retrying.

    Russ

    • I have tried to update both from my mac laptop and from my desktop pc. The board has been plugged directly into both. I have in the past tried with nothing connected to the board and also tried with the board powered by the flight battery. All with the same failures. 

      • What is the baud rate on the COM port that you're using?  Also, you aren't connecting with the COM port, right?  You're just selecting it and then going through the firmware upgrade process.

        What happens when you attempt to use another COM port on your PC?  Does it actually change in the drop down list?

        -Mike

        • 115200. No im selecting the com port but not hitting connect. Then trying to update the firmware. It won't even work if youre connected it just says you cannot update firmware while connected to mavlink.  

          Yes changing the com port changes it in the drop down, but doesn't seem to help anything.

  • I found a solution after reading another forum. I disabeled the other serial interfaces in the device manager then uploaded the ac3.2. Hope this will help you as well.

    • What exactly did you disable? I had three com ports listed. One said arduino. I deleted the other two, but still no success. 

      • I disabeled all ports but the one saying arduino. 

        • I have done the same. But unfortunately that doesn't seem to fix the problem for me. 

  • I just now experience the same problem. Never seen it before. 

This reply was deleted.

Activity

DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
DIY Robocars via Twitter
RT @circuitlaunch: Last but not least, mystery guest @BostonDynamics Spot took to the track @diyrobocars He enjoyed the #brazilianbbq too 😂…
May 22
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race @circuitlaunch for @diyrobocars with @a1k0n Was busy in the morning and did not get a chance to tune camera…
May 22
DIY Robocars via Twitter
RT @a1k0n: This was epic. My car was barely working this morning, had to make a lot of changes and extremely dirty hacks. Post-race analysi…
May 22
DIY Robocars via Twitter
DIY Robocars @ Circuit Launch, 3/7/2020 https://twitch.tv/diyrobocars
May 22
More…