Hi,

Hope someone can help with this problem thats driving me mad. I have been keenly following and building UAV's since v1 of the mega.  Heres my current setup.

In January i bought from 3drobotics:

1 x APM 2.5+ Assembled (side entry) with 433Mhz (europe) telemetry set

1 x 3DR GPS uBlox LEA-6

1 x APM Power Module with deans connectors

Using my original Turnigy Plush 25 SC's

Using my original BL 2217/9 motors

Radio is a JR DSX11 on 2.4Ghz

Receiver is a JR RD921 9 channel rx

Heres the problem.

When i first connected the APM to MP i uploaded the 3.01 firmware.  I connected successfully and performed a magnetometer calibration and accelerometer calibaration.

I moved onto radio calibration but had some problems with binding the rx to tx to i aborted it.

After this i could not connect to MP

If i pick previous firmware in MP on the Install firmware page, and select AR2.42 AP2.74 AC2.91b i can successfully upload and connect to this. But when i go back to 3.01 i cant connect.

Using 3.01 i can go into CLI and enter commands and i have tried issuing a erase command and clear the config, which completed but still cant connect with 3.01.

I have tried 3 different windows laptops - same problem

I have tried with and without radio plugged in, speed controllers plugged in, gps plugged in etc.

Ive google for answers, the forums and watched countless you tube video.  I have successfully had my quad flying on most hardware, the last being APM Mega with OilPan shield but since this upgrade i cant proceed further.

Can any one please help me diagnose this problem and give me some suggestions to try so that i can move on.

Many thanks in advanced,

Tony

Views: 357

Reply to This

Replies to This Discussion

Update:

I have tried loading custom firmware from firmware.diydrones.com, STABLE, LATEST and one data 28th Aug, all had same results,

If i load 2.91b, after verifying the TX light on the board flashes every second

if i load 3.01, after verifying the the blue LED C flashes 6 times and 2 blinks on the TX LED then nothing.

Tony

Update, just in case i have updated the PPM firmware as recommended in the instructions, but still wont connect using 3.01 firmware.  Can anyone out there help me to solve this problem.

I'm having the same problem - has anybody helped you with this?

Hi,

In the end the board was faulty and so was the power module, had both exchanged and now works perfectly.

I could connect using the CLI and most tests failed with strange errors so this was the big clue.  Hope you solve your problem.

Tony

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service