Challenges with Telemetry ......

I recently purchased a MAVlink telemetry processor in order to get basic telemetry straight back to my Taranis+ Tx

Plugged it in and ..... not very much happened. Got in touch with Airborne Projects and we have been having a right royal time trying to get telemetry working. In case you are short of some bedtime reading ........ get comfortable and I'll begin......

Airborne projects has been very professional and has answered questions and offered advice all the way through this so I'm not complaining about them at all!

First challenge was having to roll my Tx back to version 2.0.17 as the MAVlink was compatible with that release only at the time. So reprogram Tx, rebuild drone profiles etc. All good.

Install MAVlink and Lua Scripts and we have partial telemetry. Battery voltage and altitude but no flight mode, position, heading etc. Very odd.

Contact supplier he asks if I can wait a couple of days till the OpenTx 2.1 compatible version lua software is done. So I do. 4 or 5 days later and I get a mail explaining how OpenTx actually has a bug, 2 sensors are reported as the same ID so he's built a patch and provided it to OpenTx team and it's been approved to go in to OpenTx 2.2. In the meantime he provides me with his patched version and I upload it to the Tx and rehash the tx config. All good, working nicely except ...... Still only partial telemetry and a full one time update after a reset on the hardware.

Supplier provides me with flashing tool for the Mavlink and a compiled object and I reflash the dongle. No change.

Out comes the oscilloscope and I start prodding. I can see things happening on the telemetry2 port but it looks a bit odd.Hmm Tx ( from Pixhawk ) to Mavlink is normally high - 5v and is pulling to about 3.5v. Now that is not really enough to cross to a logic low as far as I am concerned.

The Mavlink is simply an Arduino Nano so it should be logic high 5v and getting to at least 0.6v or lower. Probe deeper. take the cover off the MAVLink nano board. The serial in track is tee'd off to an led and resistor to vcc, also the the input pin of the Atmel 328p and via a resistor to a USB chip. In this case not an FTDI chip but a CH340G device. 

Disconnect the inline resistor to the CH340 and the signal going in to the Atmel Mega now looks a little better.

But telemetry still not working properly.

Hmmmm

Scrabble around in junk boxes and come up with an Arduino FIO I've been playing with. No USB on that device but also only 8mHz clock hmmm.

Connect up the FIO ( no software ) let's see what logic levels look like. Ha! Great serial bus swings rail-to-rail. Mail MAVLink supplier, looks like nano is bust. He agrees to send a new one.

I thinks to myself. I can pick up a nano overnight. Order from ebay, It arrives two days later. 

Flash it with tool provided, rewire, plug in. hmmm not much luck with telemetry. probe serial bus. BUGGER! same problem. I Smells a rat here!

Spend a day installing Eclipse dev environment and AVR pluging, instructions on web are 3 years out of date and support is CARP! Waste a day. Get eMail out of the blue from Atmel re Studio7. ( Google is watching me no doubt! )

Spend 1/2 day getting that in and all the bits in all the right places. Planning to set 8mhz target on the code and squirt it in to my FIO board. Download the repository from Airborne, slice and dice it till I can get it to compile ......... Hurrah! Change clock to 8Mhz, squirt code to Fio board, Wire up board, connect to airframe and ........

FULL Telemetry!

Ha Thinks me! I'm 2 steps ahead of the game here! ( little does I know ! :) )

Ordered replacement nano arrives in post.

Set target to 16mhz and squirt code to new nano, get it in to the Airframe....

I'll give you 1 guess ............

Nope that DIDN'T fix it! Same problem serial in bus pulled to 1/2 rail

The FIO and NANO boards are all but identical, same processor similar layouts the only difference it the USB-Serial device and the clock speed so this is a little odd to say the least.

'Disconnect ( unsolder the inline resistor ) from the USB chip to the Atmel chip on the nano and it still doesn't work completely.

Plug FIO back in ..... works great.

Nano .... dead loss FIO works great but the *mhz clock means it overflows the buffer occasionally.

That's where I am this evening.

I have ordered a couple of Arduino Mini Pros , basically an ATmega 328p chip on a breakout board, running at 16mhz so a nono without USB, They should arrive Saturday with a bit of luck. After some clay shooting in the morning I will flash one of them up before the rugby starts and try that but beyond that I'm at a loss.

Can't imagine what is causing the nano's to not work!


( Airborne has other clients in the UK that are apparently working fine. Anyone else use a MAVlink? )

Oh I have also worked out that there is enough processor capacity to act as a decoder/driver for my nav lights and position strobe leds so it's not been a TOTAL waste of a week or so! 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I realize it's a bit late, but I seem to be facing the exact same issue as you! I am using the Airborne "adapter" for MAVlink to FRsky, and I do have partial telemetry, but nothing else.

    I also mailed the manufacturer, who promptly sent me a different firmware hex file, which I flashed, but it didn't change anything. This was Friday, today is Sunday, so I'm hoping to have some news after the weekend. Let's see :-)

    Did you solve your issue? If not, what (other) solution are you using for telemetry?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…