Compass calibration stuck and failed

Hello,

I have a new tricopter frame with APM 2.6 on it. When I try to perform a compass Live calibration, it starts, but get stuck with only 3 samples saved. The figure continues to spin, but it does not take any other point.

I have checked and my board provides 3.28V correctly on the I2C port.

I have tried it with two APM 2.6 boards. I have tried it with USB connection but also with 3DR radio and I get the same results. Because of that the compass initialisation always fails.

I have tried with Arducopter 3.1.5 and 3.2beta, with mission planner 1.3.10 but also an older version 1.3.9 and I get the same issue.

3691153390?profile=original

Any help would be appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Sirglider, how did you solve this ...?

    • Double check the compass connector. I had the issue a few times and every time the solution was because of the female connector of the compass. Check that the 3 small plugs are well inserted inside the connector.

  • I have found myself the solution. My GPS+Compass Ublox LEA-6H was not configured correctly.

    See that page for details. 

    Ublox LEA-6H configuration

This reply was deleted.

Activity

Derrick Davies liked lisa TDrones's profile
18 hours ago
xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…