Compass help No mag data but compass good?

My logs show 

Test: Compass = GOOD - No MAG data, unable to test mag_field interference

everything else is good.

In mission planner I can see the heading change when moving the copter and loiter seems to work ok, but Auto declination doesn't get anywhere near the right value so I have to manually enter it and compassmot always gets 140% and up. The apm is about an inch above the pdb which is a built in pcb and the escs are under the motors. 

I was using a multiwii board with internal compass as well in the exact same spot and had no issues. I'm finding arducopter to be more unpredictable and much harder to set up so far.

Can anyone shed some light how I have a good compass but no data?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi !

    I am having the same situation.

    I am using a 2.6 APM with external GPS/mag (Crius APM clone & Ublox 8).

    When calibrating it does not rotate the coordinate systems and does not show points.

    It also has the error 99 on both mags.

    But if i am persistent in rotating i can get a calibration that makes my compass show the heading really good.

    I also did compassmot, was little before (3%) and perfect afterwards.

    (compass is about 20 cm from high current lines that i also twisted)

    BUT my Loiter is a total FAILURE thats why i start looking at things (different thread).

    My compass returns okay looking mx/my/mz/mag values.

    I tries another external mag/GPS combo with the same result.

    I also just unplugged the mag of my combo and attached a seperate mag chip via I2C (yes, my 3.3V are okay).

    Everything looks okay except the calibration "GUI" itself and the log autocheck that results in that stupid message.

    Again, heading in Mission Planner is GOOD.

    I connected an older Hexa with perfectly working Loiter / Mag / System that i built 1 1/2 years before and just updated to 3.1.5 at some time before.

    Guess what: That "known good" and "known to have calibrated perfectly" System also showed error 99 and log error message and no dots on trying to recalibrate.

    I guess there is t´something seriously broken, i have no idea if that also messes up my Loiter but i guess i proved at least ission Planner to be at fault if not the APM firmware as well.



    • I dloaded old Mission Planner versions -> e.g. version 1.3.5 is showing an animated coordinate System and sample points. No "error 99" or the like, everything okay.

      So newer MP's must be buggy, right ?



  • No i still cant figure it out. External compass gave 2% compassmot but made difference to performance. I still have unstable pitch and roll while yawing and every few flights i get bad gps health midway and high speed fly away with no rc input response resulting in a crash. I might go back to multiwii since apm is so unreliable with the slightest error. A motor failed on my hex causing it to flip and crash which defeats the point of having 6 motors. Similar esc failure on my multiwii a and landed no problem.
    • I found using an external compass made no difference, still seemed to use the internal one. Ive found any frame that has the pdb built into one of the plates causes huge interference so my apm is raised a few cm and I get pretty good hold now. I still get like 60% interference in compassmot. Manually entering the declination worked better for me. Recalibrate the compass as well.
    • I have all pretty standard equipment everyone else uses. Had a fly away with nothing but rx 3dr radio and gps
      • Hi Luke,

        that sound like my current craft !

        GPS works fine and on the ground MP shows the correct heading and Motor Interference is <1%.

        But The Analyzer shows the same "no mag data" stuff and i have GPS glitches every 3 minutes or so.

        BUT my loiter is horruble althoug the GPS position (well outside the glitch times) is perfectly precise as i can see on the log map tool.

        Did you have any explanation ? I have a crius APM clone with external Mag & gps (UBlox Neo8).



    • Too bad on your multiple issues with APM....are all your comms ref their frequencies all compatible with each other (video, mavlink, GPS, RX, etc....)

  • 3701834662?profile=original3701834649?profile=original3701834439?profile=original3701834680?profile=originalLuke, I have the same issue, did you ever get to the bottom of this discrepancy? I have seen several other discussions on the topic but yet to find a response that would shed light to " Compass = GOOD - No MAG data, unable to test mag_field interference "

    I have a stand alone external compass ( HMC5983 ).....calibration was a pass and so was CompassMot well within the limits ( 2% )  I am wondering if it had do with attempting a compass/motor interference test via Mission Planner's GUI which I was never able to get working and afterwards resorted to CLI ( command line interface ) to perform this Compass/Motor test....which was successful ( 2% )

    To date, I have carried out 4 flights and tested Altitude Hold and Loiter and so far everything appears to be working.....however, the above statement has appeared for me since day one after processing auto analysis of my data logs.
  • T3
    Sounds like you need either an external compass or get you existing compass away from interference. The compassmot I believe needs to be under 30.
    • I can't really move the board any further away unless its up on a pedestal. I don't see why I would have loiter working and a compass heading while flying and yet no compass data being logged

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25