Configuraing Elevon Mixing on APM2

Hello,

I have a Multiplex Xeno, and I succesfully  confugured Manual Mode (Radio elevon mixing), and the Stabilize mode respond correctly to pitch/roll perturbation (Elevon configuration in APM mission planer).

But the elevon input mixing changes between manual and other mode:

  • In Manual: radio Pitch stick controle Pitch
  • In Stabilize: radio Pitch stick controle only elevon 1 (right elevon  

How is it possible to switch between Manual and Stabilize if elevon mixing changes ??

I really think there is a bug or a miss-configuration about input Elevon mixing bexause don't tell me I have to change my radio mixing regarding the selected flight mode! 

Another clue: I connected AerosImRC through simulated firmware and the Elevon mixing switch can be seen between the Two modes:

3690917667?profile=original

3690917576?profile=original

Please help !

The other thing, I set the flight mode channel parameter to 5 the Mode Test interface still present Channel 8 as channel mode even if the mode changing wotks correctely. I did not have this behavior on APM1&Arducopter.

3690917681?profile=original

3690917702?profile=original

Thanks a lot.

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,

    I got back My APM2 board. The Serial converter was fried. So I am back into the Ardu-Xeno plane.

    About Elevon mixing configuration, described in the Wiki the Manual mode is configured first. So I cannot understand how this could work every time. Because once Manual mode works correctly, what to do the the APM Stabilisation reaction is not correct?

    I think there is a mistake in the WIKI:http://code.google.com/p/ardupilot-mega/wiki/APM2ReversingTop?wl=en

    I think the good strategy to configure correctely the APM is the following:

    • Calibrate Radio Channels
    • Set the APM to Stabilise mode and change Elevon reverse mixing until the APM stabilisation reaction is correct:
    • THEN switch to Manual and configure your radio to work correctly in manual mode.

    .

    .

    Am I wrong ? Did I miss something ?

  • I guess this thread is a little old, but my HUD response is reversed in elevon mode...is anyone else's like that?

    Thanks

    JC

  • Phil has it in the screenshot up here ^^^^^^^

    I have elevons, stabilize and rc input working on a Zii with those same configs.

    HOWEVER, I have my dual-rates turned way down, and after multiple radio calibrations/resets, I still get full deflection in stabilize mode on RC input.

    I need those dual rates to carry over in stabilize.

    Am I missing something?  Thanks!

    JC

  • Which SW version are you using? Downloaded from the planner?

  • If the elevons work correctly in manual but not in stabilize it's most likely that you have not configured APM properly.

    If you're sure that you have elevon mixing enabled in the APM EEPROM check that you have the reversing switches disabled. This should happen by default in APM2 since it doesn't have any reversing switches, but it's possible that it didn't.

  • Developer

    the planner doesnt register the channel change, i will need to fix that.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…