Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello, really need your help. Connected to the xbee 868 apm2.5, everything works fine, but after a while xbee stops working since 10% of the limit (10% duty cycle). Tell me please: how to implement an automatic reset every 5 minutes.

  • I'm having this same problem. I'm using MP 1.2.34 and ArduCopter 2.9.1 for Tricopter. I had been able to use my 915mhz 3DR radios until I powered up and a friend connected to my tri when trying to connect to his quad, since we were both running default settings at the time. I connected to his as well when I tried to connect. Once we sorted that out, I haven't been able to connect telemetry since. I get "Getting Params.. (sysid 1 compid 1)" then "Connect Failed".

    I've tried resetting to defaults, switching USB-side radio (I have 2), still no luck. Any suggestions? when I try the Ctrl-T method, it seems to connect sometimes, but it never loads any stats or data. 

  • I have a set of 3DR Radios 433Mhz, that Works fine. I want to use Bluetooth to communicate With my Nexus 7 Android Tablet.

    When searching the net for a Bluetooth module, I fund this one:


    5V TTL, and set to 57600

  • Developer

    have you cahnge the settings ive talked about.

    via usb.

    change sr3_params to 10

    change sr0_params to 10.


    change all the sr0_* and sr3_* to 0, these will be reset on the next connect.


    and in the planner config screen change the telemertry rates lower.

    to say 5 1 1 1


  • CTRL-T.
  • Can you solved the problem? how? I've the same problem, but I've XBEE PRO 868.
    Any suggestion?
    Thank's for all.
  • Hi

    I had the same problem. I just had to turn off the uart flow control and then everything was fine.

  • I have the same problem. No Xbee telemetry anymore. After clicking on connect, it tries to communicate then waits 30 seconds and finishes with an error message: 


    Your serial links is not fast enough.


    I tried "Brady D" solution and nothing changed. I changed the baud rate (in both Xbee's, firmware and MissionPlanner) to 38400 but still the same problem. Still not sure if it is a hardware or a software problem. I thought it could be a circuit noise so i disconnect all sensors from the board keeping only the xbee but that still not changing any thing. this disappointed me the who day.

    I am using the flowing hardware/software:

    Xbee modules: 2.4GHz XBee XBP24-AWI-001:  http://www.sparkfun.com/products/8742

    Xbee explorer on laptop side:    http://www.sparkfun.com/products/8687

    Xbee explorer on ArduCopter side: http://www.sparkfun.com/products/9132

    ArduCopter firmware: ArduCopter-2.5.5

    Mission Planner 1.1.92



  • Hi all


    Everything was working perfectly (5 months ago) and started to not connect more! I see that is a recent problem!

    Can anyone help and set the cause of the problem? 



  • So I won't claim that the following is a solution, it is merely the last thing I tried before it started working. It may be unrelated. 


    Then I turned all the data transfer rates (attitude, position, etc...) down to 1Hz and tried to connect. Connection worked. Then simply turned the rates back up to desired. Seems to be working. 

This reply was deleted.