Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello, really need your help. Connected to the xbee 868 apm2.5, everything works fine, but after a while xbee stops working since 10% of the limit (10% duty cycle). Tell me please: how to implement an automatic reset every 5 minutes.

  • I'm having this same problem. I'm using MP 1.2.34 and ArduCopter 2.9.1 for Tricopter. I had been able to use my 915mhz 3DR radios until I powered up and a friend connected to my tri when trying to connect to his quad, since we were both running default settings at the time. I connected to his as well when I tried to connect. Once we sorted that out, I haven't been able to connect telemetry since. I get "Getting Params.. (sysid 1 compid 1)" then "Connect Failed".

    I've tried resetting to defaults, switching USB-side radio (I have 2), still no luck. Any suggestions? when I try the Ctrl-T method, it seems to connect sometimes, but it never loads any stats or data. 

  • I have a set of 3DR Radios 433Mhz, that Works fine. I want to use Bluetooth to communicate With my Nexus 7 Android Tablet.

    When searching the net for a Bluetooth module, I fund this one:

    http://www.ebay.com/itm/30083553192sing

    5V TTL, and set to 57600

  • Developer

    have you cahnge the settings ive talked about.

    via usb.

    change sr3_params to 10

    change sr0_params to 10.

     

    change all the sr0_* and sr3_* to 0, these will be reset on the next connect.

     

    and in the planner config screen change the telemertry rates lower.

    to say 5 1 1 1

     

  • CTRL-T.
  • Can you solved the problem? how? I've the same problem, but I've XBEE PRO 868.
    Any suggestion?
    Thank's for all.
  • Hi

    I had the same problem. I just had to turn off the uart flow control and then everything was fine.

  • I have the same problem. No Xbee telemetry anymore. After clicking on connect, it tries to communicate then waits 30 seconds and finishes with an error message: 

    -----------------------------------------------------

    Your serial links is not fast enough.

    -----------------------------------------------------

    I tried "Brady D" solution and nothing changed. I changed the baud rate (in both Xbee's, firmware and MissionPlanner) to 38400 but still the same problem. Still not sure if it is a hardware or a software problem. I thought it could be a circuit noise so i disconnect all sensors from the board keeping only the xbee but that still not changing any thing. this disappointed me the who day.

    I am using the flowing hardware/software:

    Xbee modules: 2.4GHz XBee XBP24-AWI-001:  http://www.sparkfun.com/products/8742

    Xbee explorer on laptop side:    http://www.sparkfun.com/products/8687

    Xbee explorer on ArduCopter side: http://www.sparkfun.com/products/9132

    ArduCopter firmware: ArduCopter-2.5.5

    Mission Planner 1.1.92

    xbee1.JPG

    xbee2.JPG

  • Hi all

     

    Everything was working perfectly (5 months ago) and started to not connect more! I see that is a recent problem!

    Can anyone help and set the cause of the problem? 

    Thanks

    3692413532?profile=original

  • So I won't claim that the following is a solution, it is merely the last thing I tried before it started working. It may be unrelated. 

    AMP>>Config>>Planner

    Then I turned all the data transfer rates (attitude, position, etc...) down to 1Hz and tried to connect. Connection worked. Then simply turned the rates back up to desired. Seems to be working. 

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…