Hello, I have loaded the latest (2.0.33) code and used both mission planner and CLI to do the setup, but even though I can take off and have a level flight, the copter is rotating constantly clockwise...I have about no control over the yaw.

I am using the DIY mag and also have a sonar attached.

Any ideas?

 

P.S. My mag is attached as follows:

Components Up, Pins Forward

 

Views: 858

Reply to This

Replies to This Discussion

If you don't attach the mag the way the manual instructs (components down, pins forward), you can't use the standard firmware and must edit the code and compile it with Arduino yourself.

http://code.google.com/p/arducopter/wiki/AC2_Magnetos

Out of curiosity, why didn't you attach your mag the recommended way?

Thanks I will flip it over...I had it that way originally, but somewhere along the way I read that it should be Components Up..

Since I thought this might be the cause, I tried disabling it in the CLI (the mag), but it made no difference.

I will update in a few minutes after trying it enabled and flipped.

 

Just made the changes and tried to fly, same result..just yaws clockwise...I can stop it for a second with the stick control, but as soon as I release the stick, it starts the yaw again.

Note, it is flying level the entire time..just spinning.

I just found where I saw to put the mad Components Up as default..

It was (still is) in the wiki manual

Since I am using the cable method, this seemed to be correct?

#define MAG_ORIENTATION  AP_COMPASS_COMPONENTS_UP_PINS_FORWARD       // This is default solution for ArduCopter
//#define MAG_ORIENTATION AP_COMPASS_COMPONENTS_UP_PINS_BACK // Alternative orientation for ArduCopter
//#define MAG_ORIENTATION AP_COMPASS_COMPONENTS_DOWN_PINS_FORWARD // If you have soldered Magneto to IMU shield as shown in the Wiki

Can you check that you have the props spinning the correct directions?

 

See here

Gotcha. That was a legacy of the old NG code. I've updated it.

Possible causes are motors tilted or ESCs not calibrated right. Check the Troubleshooting guide:

http://code.google.com/p/arducopter/wiki/AC2_Troubleshooting
This is not the default for "cable", it is a example of the code change that needs to be made if you have changed to this mag configuration. This code change cannot be done using the CLI nor the Mission Planner.

Motors triple checked, no tilt, and ESCs are calibrated via CLI.

Note, copter does fly perfectly level, just spins in circles.

Old Pirates NG worked perfectly though?

What I am hoping to get out of this code is the "Simple" mode working well.

 

Are you using latest code (2.0.33)?
Mag checks out fine in CLI tests or Mission Planner artificial horizon (or mag is disabled)?
Prop rotating/counterrotating type checked?
You haven't touched the trims on your radio?

One way or another it's a setup error. We'll just have to track down which one.

You might want to try calibrating the ESCs by hand, as described in the manual.

Yes, to all the above, the props all spin up at the exact same time, but I will go ahead and do a manual ESC calibration.

I do think it is something simple I must be doing wrong.

 

Also, if your Tx calibration did not go well. If the yaw cal does not center for some reason.
Is the mag enabled or not?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service