Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Having an unusual issue with all motors spiking in throttle after SECOND arming event. The problem goes as follows. 

    -  Quad plugged in. 

    -  All Pre-arm checks passed

    -  Arm Safety switch depressed

    -  Quad armed via Tx and flown with no issue

    -  Land and disarm via Tx (Without depressing Arm safety switch. Switch remains illuminated as steady red)

    -  Immediately after arming again all motors spike to 50% power.

    -  When Tx throttle moved slightly above low point and quickly back to low all motors respond as expected and I am able to takeoff from there without any problems. 

    Any subsequent attempts to takeoff following the above sequence repeats the problem continuously. If i unplug everything and then start from step 1, the first takeoff is always as expected. The problem only occurs on the second takeoff event as described. The included photo is from the log file showing a graph of my throttle input to capture the motor runaway and bring them back to low for normal takeoff. This problem presents itself regardless of the flight mode used during takeoff. Acro and Stabilize

    Ps: Previous issue with stability solved. Quad gimbal flex was causing High frequency oscillations (above what pixhawk can measure?). Auotune did its job and provided the highest PID possible while minimizing issues. Once the Gimbal twisting issue was solved autotune PID's provide a rock solid multi-rotor. Excellent job guys.

    armissue.jpg

    https://storage.ning.com/topology/rest/1.0/file/get/3702054973?profile=original
    • Developer

      Maury,

      Thanks for the report.  It looks like you've downloaded the dataflash logs, could you post them here as well?

      • bin file from flight

        https://drive.google.com/file/d/0By12f3-1EZywazZJUndqdmxXUDA/view?u...

        The .bin file is included in the link. It is ~30mb since it was a 15min log. I went back to rc 3.7 and the issue is there as well. 

        • Developer

          Maury,

          Ok, I have a guess as to the issue.  I think that the earth frame rate targets are not been reset when the vehicle is landed.  I've added the reset and also made the motors "slow start" in stabilize and acro.  If you're feeling a bit brave, could you give this modified firmware a try?  It will appear as AC3.4-dev but it's really extremely close to AC3.3-rc8 with the exception of these few changes.

          Note: to download the firmware linked above, I found I needed to right-mouse-button-clicked and selected "Save Link As.."

          AC_AttControl: relax earth frame rate targets along with bf · rmackay9/rmackay9-ardupilot@41a00c5
          Randy's fork of ArduPilot. Contribute to rmackay9/rmackay9-ardupilot development by creating an account on GitHub.
          • Randy,

                 I'll upload the firmware to my Multi and give it a shot over the next few hours. Let you know how it goes when completed. 

            • Randy,

                   Firmware uploaded and...

              -  immediately upon power up I am now getting the Pre-arm failure - Inconsistent Compass with yellow flashing LED light. The failure can be cleared by rotating the entire multi 5-10 degree's along the Z axis and the check clears and will not return until the next power up (battery plug in and out). The error repeats at every startup. In some cases moving the multi 2-3 feet by hand laterally has also solved the problem. 

              -  Bad AHRS error appears randomly and goes away. I was unable to induce the failure nor was i able to determine the solution to the failure that caused the issue to clear. The failure occurred every 3-7th power up sometimes after being powered on for 1-2 minutes. other times it was the initial failure reported through mission planner.

              -  Once I was able to get it it to arm I can confirm that the throttle response is now identical for every arm disarm sequence. across 2 15 min events with varied time spent in the air it was armed and disarmed 16 times with no issues from the motors. 

              Any ideas as of to why the sudden pre - arm check failures?

  • I finally got to testing the large quad again with 3.3 RC7 after changing mounting options and ensuring throttle min was set properly and we have the same issue with it flipping. It seems to always happen after yaw inputs.

    I am completely clueless as to what could be causing the problem as when I look at the logs I don't see anything wrong and there was no mechanical failure.

    Logs attached.

    2015-07-25 16-54-38.bin

    2015-07-25 16-53-47.tlog

    • Developer

      Jason,

      I think it's a mechanical failure of some type affecting the front-right motor.  It's likely this motor because the vehicle flips right and forward and that motor's output (#1) goes to max while it's opposite (motor #2 on back left) goes to it's minimum.

      There's also a moment just before the flip where (perhaps due to the yaw demand) that motor goes low.  The #1 motor going low should not be a problem but it could be if that ESC isn't calibrated correctly or the THR_MIN is too low.  I see the THR_MIN has already been increased from the default of 130 to 160 so it's a bit odd - my guess is that all the ESCs should be calibrated again.

      3702582716?profile=original

  • I saw that the 3.3rc8 was out this morning so I couldn't resist, I loaded it and went to my best testing grounds to see how it went.

    I had just loaded 3.3rc7 a few days back and it worked well. On the rc 7 I was unable to test the GPS dependent modes but this tine I did.  

    The wind wasn't bad but was gusting a bit and it happened to when I was arming it.  The props spin to fast when it arms.  I guess there is parameter to adjust for that, but when I arm, it is hard to keep it on the ground.  So, it tipped over.. Do damage, so I gave it a second try. As soon as I cleared the ground, it was flying very smooth and stabile.  I placed into Alt hold and it was only about 3 meters off the ground and it held it for a short time, then dropped and did a soft touchdown and then I too it back up and hovered a bit.  This time it held altitude well, so I took it up a bit higher and engaged poshold.  It was pure pleasure from that point on. It was smooth, locked in and I conservatively to simulate taking some camera shots.  In fact I was running my GoPro at 4k 15fps to explore the concept of shooting 4k to get lots of high res photos, that works well BTW!  I had one anomaly, the MinumOSD was telling me I was still in Althold, even though I was in PosHold for most of the ride.. perhaps MinumOSD needs an update..

    I had no other issues, so I really like this release.. Tommorrow I will put on the googles and do some FPV..

    attached is the Flash log

    44.BIN

    • Developer

      Richard,

      Thanks for giving it a try.  I think you have a very powerful copter (with a 6S battery?) because it hovers at about 36% throttle.  I see the THR_MID is set to 460 so that could be lowered a bit (maybe down to 400) to give you more control at the low end.

      I suspect you can also lower the THR_MIN value to free up more control at the bottom end.  The default is 130 (which is what your vehicle is using) but that's quite conservative.  I suspect you could lower it to 90 but that's a guess.   It depends upon the deadzone of the particular ESC being used.  If you lower this value you might also want to set MOT_SPIN_ARMED to a lower but non-zero value.  So maybe MOT_SPIN_ARMED to 70, THR_MIN to 90.

      I'm sure you know, setting MOT_SPIN_ARMED to zero means the props don't spin until you raise the throttle - this is fine, some people prefer this but using MOT_SPIN_ARMED is useful for finding out how big the ESC's deadzone is at the bottom.  So you can set MOT_SPIN_ARMED to just enough to get the motors spinning, then set THR_MIN 20 or 30 pwm higher to add more insurance that they'll keep spinning in the air.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…