Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Hey guys just thought I would pop in to say I have just got this working...mostly. I am using a Basecam 32 bit 3 Axis BGC and successfully controlling it using Serial 2 out of a Pixhawk 2 (From a SOLO main board but I think it would be the same on a Pixhawk 1)

          Connections are such:

          Pixhawk Serial 2 Tx -> RC_ROLL

          Pixhawk Serial 2 Rx -> RC_YAW

          Settings on Pixhawk:

          Serial 2 BAUD rate: 115200

          Gimbal Type -> Alexmos Serial

          + assign control channels (eg mine are RC5 and RC6)

          Settings on BGC (Basecam):

          RC -> Input Mapping -> RC_ROLL pin mode -> SBGC Serial API 2nd UART

          I have this confirmed working, though I have the following issue:

          The output to the gimbal is only changing at a set rate, regardless of the speed at which I change the input. For instance, if I try to pitch down within a second, I see the RC6 input changing correctly, but the gimbal changes speed at the same slow rate, resulting in a significant lag. I have tried changing setting on the BGC to no avail - if I control the gimbal with PWM and the same settings the gimbal moves as fast as I want it too. Thus, I am fairly certain that it is an issue stemming from the flight controller. 

          Randy, perhaps you may be able to shed some light on this for me?

  • I have a strange problem with RC7, after first flight when I landed and disarmed the motors kept spinning, tried to use "Motor Emergency Stop" that I have on channel 7 but that didn't help either, had to press the safety switch to stop them.
    I calibrated the ESCs after upgrade to RC7

    Log is to big to upload so I have it here

    • Anyone that could have a look at this?

      I've tried to reset the Pixhawk completely, installed APM:Plane and then back to Copter 3.3 RC7, done all calibrations again including ESC calibration. After ESC calibration it looked OK but then after first flight I got the same problem, motors continue to spin after disarm and even if I use Emergency Stop, I have to use safety switch to stop the motors.

      • Will upgrade to RC8 and test instead.

  • Sorry to become a little bit OT.

    I just build up a new Copter, because of my Taranis Issue.

    I use a GPS N8M which I have to mount in its opposite direction. See Picture!

    COMPASS_ORIENT=12 (pitch180) and did my Compass calibration with MissionPlaner.

    Sometimes the Compass show North (the Copter front looks to North) some times East or West. Of course I can´t Arm the copter. I disable the compass check and after 2 min. flight I crashed. (my fault because of disarming the Check).

    Unfortunately I cant Upload a Log because of "error receiving log list"

    Is the COMPASS_ORIENT=12 correct?


    • So now I tried nearly every combination. The best was pitch=180 for the Compass_orient(0).
      But then I got always Compass inconsistent warning.

      I give up and extend the wiring, to be able to turn the compass 180°

      • Interesting.

        I had exactly the same problem with my first M8N combo.

        It acted strangely, and I've got almost always inconsistent compasses warning.

        The warning would occasionally went away, but I wasn't confident about it.

        I thought it was a faulty unit so I replaced it with another one which has orientation none.

        It could be that 3.3 doesn't like for some reason the pitch 180 setting...

        • not only 3.3, but also 3.2.1... I have an X2 board which I needed to yaw 180deg for cleaner wiring. so for 3dr gps/compass I was trying to find yaw180/roll 180, but there is only pitch 180 which I do not believe works as after choosing this setting my mag heading is off by 45deg... It happened only recently and I contributed this to my own oversight in some settings, however after reading this post I double checked everything and it is still the same erroneous heading and "compass inconsistent" message. 

          • We had a problem rotating an M8N 180deg in the roll axis....similar outcome with the heading being 45-90deg off...

            • have you figured it out? 

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25