Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • I'm still not able to calibrate properly.. 
      I had APM 3.4 on it.. So, to start I put px4 back on it.  Ran through all the calibrations.  Took off and flew for a min.. No problems.

      Put APM 3.3.3 on it.  Same issues. 
      I calibrate accels.  It doesn't save the settings.  I do it again.  It does save.. My HUD is spinning.  Do it again.  It works!  Reboot.  It works!  Reboot again, "bad gyro health", reboot one more time "Accels not calibrated". 

      I don't know, but it seems to me like maybe it is not properly saving the values after a calibration.. Or it does, but they become corrupted after rebooting.. Maybe that explains why it worked after one reboot.  Had bad health after the next, and the settings were totally gone after the 3rd. 

      • Someone suggested I try today's 3.4 master build, and it does seem better!
        It is remembering my calibrations after rebooting. 

        I still get bad gyro and accelerometer health warnings, but maybe less often... about 1 out of 5 times I get no errors and can arm.  

        I'm happy to test things and provide logs if it would help. 
        Otherwise, I think my original question is answered..  It's not quite as ready as some were implying, and my board is most likely fine. 

        Thanks!

        • i get those warnings sometimes with 3.3.2 but only when its cold outside. 

        • Developer

          Scott,

          That all sounds very bad. There are differences between Copter-3.3.3 and Copter-3.4-dev but the low level drivers all the same.  I think it's too early to be sure that it's a firmware issue.

          In any case, I've created a new discussion for discussion about the Pixracer with Ardupilot so could you post a binary log file over there so we can try and get to the bottom of this?

  • Developer

    I'd like to push out Copter-3.3.3 as the official version in the next day or so.  Has anyone given it a fly and can confirm that it seems ok or not?

    We will do a special build so pixracer will be officially supported using Copter-3.3.3 at the same time.

  • I want to mention, so my logs and info don't get lost in the chatter...
    I did successfully load APM, and fly with it. 

    It's just that the compass settings sometimes get lost/erased if I hook it up to the computer. 

    And, I get gyro and accel prearm warnings most of the time. 

    I'm wondering if this is possibly issues because it is in development, or if these things should be working, and I should look in  to an RMA?

    Edited to mention, I have the same issues in MP and QGC with the config not saving (it goes through the steps, but then keeps saying I need to calibrate the compass).  No problem installing the developer version of the software.

    • Developer

      We think the pixracer should work.  I don't believe there are any known issues in the software.

      I know there was a change to the board's design (before it was mass produced) to move which (SPI?) bus the eeprom was on which could be related to the issues saving parameters.  Or it could be unrelated... for example if the compass was not being reliably detected at startup then it could also lead to the "Compass not calibrated" pre-arm check appearing.

  • Can someone help w/ pixracer APM support?  This isn't exactly 3.3 related, but seems like the best place to post.  (And sorry for double posting, I already mentioned this in the pixracer blog, but don't think I can attach logs there)

    So, my pixracer seems to function properly w/ PX4.  I haven't flown much, but it sets up/calibrates ok. 

    APM doesn't work.  I think I am narrowing down some of the issues to the USB connection (I have used different cables/ports, etc)
    I plug the board in to my computer.  Program it w/ Qgc using APM alpha.  It programs fine.  I calibrate.  It goes through the steps, but doesn't save.  I look at the parameter list, and the offsets are there.  But, it keeps telling me I need to calibrate the compass. 
    I disconnected the USB, and calibrated it over the telemetry modem, and the settings saved! 
    But then, I get "bad gyro health" and "accelerometer unhealthy" (or something similar) 9 out of 10 power cycles. 
    And finally, sometimes all the compass and accel calibrations are lost.  What's strange to me is my RC config and tuning remains, but the compass and accel settings are all back to 0's in the config.  I think this (cleared settings) only happens when plugged in to USB.  And it seems to be when I unplug from USB, it reboots the board, and the next time I plug it in those settings are gone.  And again, I have tried different cables and ports, and even 2 different computers.

    Logs attached.  First one is when I enabled logging and was getting the gyro health error.  The second one is after unplugging the board, rebooting, and my compass settings were gone. 

    2016-02-08 14-44-49.bin

    2016-02-08 14-45-58.bin

    • I just ordered one myself I hope I don't go through the same issues.

      So are you saying it seems to work okay with the PX4 firmware but not the APM firmware? Hopefully it's something that just needs tweaked in the settings. Please post back here or over at http://diydrones.com/profiles/blog/show?id=705844%3ABlogPost%3A2170...  if / when you figure it out. I would suggest emailing them directly over there at sales@auav.co  Hope it gets sorted out I was going to be running 3.4 dev myself. Have you tried 3.2 or 3.3? Do you have a gps with external mag? Perhaps disable the internal and see if that does the trick?? 

      • I have been in contact with Nikolay at AUAV. The APM stack does not communicate with the pixracer at this time. He assured me that the developers are working on it and should have a fix in the next couple of weeks. With multiple voices it might raise awareness.

        Cheers,
        Randy
This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…