Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Sorry Randy - forgot to attach the logfile.

    In this log, I was flying in RC controlled mode, always connected to Tower.

    I landed, disarmed, then re-armed in Tower, pressed Takeoff and went into FollowMe. Then I pressed Pause and the drone immediately banked away. I could rescue by switching flight modes on my RC. (in panic I switched to Auto for a split second - this was not the reason)

    I reproduced this in another flight, after pressing Takeoff in Tower, I pressed Pause when the drone banked away again.

    I would classify this as a "flyaway" kind of defect. AC3.3.2, latest Tower release, Lidar enabled.

    Thanks for looking into this.


    • Hi Stephan,

      Do you also have access to the tlog files for this issue?

      - Fredy

      Tower lead developer

      • Hi Fredy,
        I am currently on a business trip- will get back to you by Thursday
        Thx Stephan
    • Tried this today with fw 3.3.3 and tower app.

      Just to make sure that I did everything the same way:

      1. Armed in stabilize and took off
      2. switched to pos hold 
      3. switched to follow me in tower
      4. walked around with the drone following
      5. switched to pause in tower

      The drone did what it shoud - it stopped in Loiter.

      Did this error only happen when drone is armed via tower?

    • That's a little dramatic :)

      • Well for someone less experienced it would have likely ended crashing somewhere in the wild.
        So yes, I would consider the incident serious.
        • Apologies, the f-ing forum software truncated my answer again..  I was also  trying to say that the term 'flyaway' seems to be used for circumstances where you lose complete control of the craft and nothing you do regains control.  There are lots of circumstances where it can behave unpredictably or erratically in various automated modes (toilet bowling, gps glitches, various recovery or failsafe actions, gcs bugs etc etc) but if you can flick it back into stabilise mode and regain control or into RTL and have it return, then from what (little) I understand then this isn't classed as a 'flyaway'.  In guided mode you're somewhat at the mercy of the GCS, although it's possible it's a bug in the guided mode itself.

          It's an important distinction - phantoms are well known for proper flyaways where it's impossible to regain any kind of control, whereas it's extremely rare in APM (not bashing phantoms, just an example that comes to mind).

          • fnoop dogggiee lost interest reading your comment past your name and first sentence. But i still did....

            What Stephan is experiencing sounds very troubling. And you are not helping ANYONE with your comment. If you want to help try to reproduce this issue yourself with logs to see if more people see this issue and not just BLAH BLAH BLAH and BLAH

            • Developer

              Let's all cool down here.  No more comments on this until I review the logs please.

            • Thanks for your intelligent contribution.  As you can probably tell I chose my name specially so people who sound like moronic teenagers with room temperature IQs can feel superior to themselves.

              To Stephan and the rest of the thread apologies if I didn't come across well, I was just trying to be helpful but guess I didn't achieve that.  Actually I did spend quite a bit of time looking at the log - as I often do in the background to try and learn about bit more about the inner magic of the firmware.  Relevant EKF looks OK at the time, it's worth noting you have reasonable vibrations at times and a bit of clipping but I don't think that's relevant to this issue, but around about 4900000000us there's a sudden yaw and change in direction.  My kung fu isn't good enough to tell why exactly and point fingers so I just tried to point out that it's not uncommon for this to just be the FC doing what the GCS tells it to - it doesn't look like a fault, it looks like a deliberate change, and there's no indication of an error or failsafe from the FC and there's no modechange so it implies this comes from the GCS - I don't know how to read the GCS commands so I can't say for sure.  Hopefully Randy will be able to actually tell you what happened.

This reply was deleted.