I am trying to figure out a way to run any simulator of mission planner on my computer, I am running a fairly old Gateway ID49C with Windows 10 on it. I have tried following this wiki http://ardupilot.org/dev/docs/sitl-native-on-windows.html about six times with no luck so far. It seems no matter what I do I can ever get it to work, and  its making very frustrated, to the point  that I am starting to think I should take programming lessons of some sort. What do you guys recommend? I feel like I am illiterate in this environment.

Anyways should l I give up on the Windows tutorial and try to go th Linux way with Ubuntu?

Any comments, even mean ones are welcome. I am trying to reach out for help here.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Im on vacation, but use mavproxy as primary GCS, then add parameter --out udp: (check syntax) qGroundControl,  ApmPlanner2 will automatically connect, not sure with MP as I don't use it.

  • Hi Andre, maybe you can help me,  I have followed the instructions on this wiki http://ardupilot.org/dev/docs/setting-up-sitl-using-vagrant.html# , and for the most part it seems to be working, I do get an error shown in the attached picture, do you know what this is al about? Also, it is required to run MAVProxy at the same time as I run Mission Planner to input commands or I can do that through the VM?  I would appreciate if you could help me with this



    Setting up SITL using Vagrant — Dev documentation

  • Thanks Andre, I shall give it a try then, hopefully it will go better!

  • Most developers (by far) use linux, you should have way better chance for success there.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25