Dangerous condition with gimbal settings

I have an octo and am installing a gimbal using the wiki. I've done this before on quads but not with an octo.

http://code.google.com/p/arducopter/wiki/AC2_Camera

Since I'm using digital servos, I wanted to set to another channel since A10 and A11 are 50hz. In the MP it doesn't allow choosing A9 but does allow A5-8. So I moved my pitch and roll to A7 and A8 and chose RC8 and RC9 in the MP. First it didn't work so I decided to change it back to A10 and A11. I'm just using the servo's signal wire and powering the servos via 6v BEC. I first changed the signal wires to A10 and A11 and then booted up the APM2.5 so I could change it to RC10 and RC11 in the MP. After about a minute or less, some of the motors spun up. Not so much to lift off but if someone was near one, they would have had some problem. Note that the Tx was on, MP was auto reconnecting and copter was of course disarmed. I had just plugged it in. So I pulled the battery and tried again. It happens every time. The only solution was to have someone hold down the octo while I changed the MP to use A10 and A11, then the motors stopped.

Is it possible the octo code is occupying these channels for some of it's motors? I noticed it was the same few motors each time.

What should I use for digital servos? A5 and A6?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    I've raised an issue here and I hope we can fix it soon.  Maybe for 3.0 'cuz we tend to prioritise safety issues.

  • Developer

    F11music,

         Thanks very much for the report.  So the issue here is that you set it up so that it's trying to use RC7 and RC8 for the gimbal but on an octacopter those are used for the motors.  So when it initialises the gimbal it fires up the motors!  We should make this impossible 'cuz it'll never work and it's dangerous.

         The other confusion is that on the side of the APM2.5 case RC10 and RC11 are labelled as A10 and A11 which makes you think that RC7 and RC8 must be the same as "A7" and "A8" but they're not.  A7 and A8 are on the back of the APM2.5 where you already have your octo motors attached.

  • Hey i had similar issue earlier.

    I think i was on 2.9.1, with apm 2.5 + PM, a Y6 with 800kv sunnysky, F30 simonk flashed esc, th9x.

    Activated the A10 and A11 for gimbal, using BMS analog servo. First test, it doesn't work. The servos just wouldnt move whenever i roll or pitch the Y6, with hand. And after a minute, the rear two rotors would spin itself, slowly. dangerous! Few batt reset, still the same symptom.

    After 2 3 times of erasing eeprom, reloading the firmware, the gimbal works and that self spinning never happens again.
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…