I have set up ardupilot with the shield installed and xbee 900's to transmit the data. all the blinking lights seem to be good. eg. i get satelite lock on gps. i also see data being transfered from the xbees as the lights on the adapoters are blinking. in my terminal i have set it to 57600 (i also used xtcu to sety my xbees to 57600 for the em406 adapter) and all i get is garbled data. its not readable. i think i have missed something but im not sure where.

**sorry for my first post it got screwed up somehow alot of it didnt show up and the title was gone.

Views: 254

Reply to This

Replies to This Discussion

You'd get more help if you'd give your forum posts a proper title. There is not enough information in your question to answer it. Are you using ArduPilot? Something else?
One thing to try is disconnecting the GPS to make sure it's serial interface isn't interferring with the airborne XBee.

After than you might want to reconnect each Xbee to your PC (via xtcu) to check that the baud rate was actually changed on both radios.

If you have the needed cables/adapers, you can also try connecting both XBee's to either the same PC (different USB ports) or separate PC's to see if they can communicate properly. (open a separate terminal window for each one)

You can also connect the Rx and Tx pins on the remote XBee (the one that goes in the plane) to just have it send back whatever it receives as another way to test the link.
What adapters are you using on the xbees? If there are LEDs on the TX/RX lines they could be drawing too much current and the signal quality could be too low. We recently ran into that problem with some Spark Fun xbee adapters.


iv double checked everything and my settings are ok. the data comes as packets just not readable. the xbees are talking but not well. when i disconnected the gps the data stoped trasmitting. one more sympton i have is the gps red light is very dim as in you can only see a dot in the led.perhaps my shield is ng. i will try without the shield
Here's what's happened. ArduPilot has programmed your GPS into binary mode, as intended (that's why the LED is very dim). What you're looking at is binary data, which is why you can't read it. If you use the ArduPilot code, which parses the GPS binary, you should should see the data coming through right.
what do you mean by use the ardupilot code. is there a setting i need to change in the code?
Shawn,

I believe that Chris means the Ardupilot Ground Station program.

Just a thought.

Regards,
TCIII
yea thats what i thought. i tried but didnt work, i will try again when i get home. thanks for all the help guys.
Sorry, I'm confused. Are you just looking to see the output from the ArduPilot code? Have you tried just reading it from the FTDI?
im trying to read the telemetry data from the xbees. i have my latop setup to recieve the data from the xbee 900's.
very strange everything appears to be working perfect except for this. i tried the ardupilot ground station get no reaadings. i didnt mention i dont have the xyz sensors installed (havnt got them yet) could that be causing it?

it really looks like the baud rate is off some how. in the manual it states 57600 for the EM406 is that right?
Do you guys thik it could be my shield causing the error. it looks good but only thing i could think oh?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service