DATA Transfer problem with ardupilot and xbee 900

I have set up ardupilot with the shield installed and xbee 900's to transmit the data. all the blinking lights seem to be good. eg. i get satelite lock on gps. i also see data being transfered from the xbees as the lights on the adapoters are blinking. in my terminal i have set it to 57600 (i also used xtcu to sety my xbees to 57600 for the em406 adapter) and all i get is garbled data. its not readable. i think i have missed something but im not sure where.**sorry for my first post it got screwed up somehow alot of it didnt show up and the title was gone.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 3D Robotics
    Shawn, why don't you try connecting ArduPilot directly to your computer with the FTDI cable and reading the data with the Ground Station software. If that works, then you know that the problem is in your Xbees.

  • iv double checked everything and my settings are ok. the data comes as packets just not readable. the xbees are talking but not well. when i disconnected the gps the data stoped trasmitting. one more sympton i have is the gps red light is very dim as in you can only see a dot in the led.perhaps my shield is ng. i will try without the shield
  • What adapters are you using on the xbees? If there are LEDs on the TX/RX lines they could be drawing too much current and the signal quality could be too low. We recently ran into that problem with some Spark Fun xbee adapters.
  • One thing to try is disconnecting the GPS to make sure it's serial interface isn't interferring with the airborne XBee.

    After than you might want to reconnect each Xbee to your PC (via xtcu) to check that the baud rate was actually changed on both radios.

    If you have the needed cables/adapers, you can also try connecting both XBee's to either the same PC (different USB ports) or separate PC's to see if they can communicate properly. (open a separate terminal window for each one)

    You can also connect the Rx and Tx pins on the remote XBee (the one that goes in the plane) to just have it send back whatever it receives as another way to test the link.
  • 3D Robotics
    You'd get more help if you'd give your forum posts a proper title. There is not enough information in your question to answer it. Are you using ArduPilot? Something else?
This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race with @a1k0n at @diyrobocars We both decided jumping over the wall was the way to break the 11s lap time. Th…
Aug 14
More…