Does ArduCopter RC2 hard to fly?


I have been using the Alpha version for months now and everything seems to be fine, now I decided to give the ArduCopter RC2 a try, I uploaded it and configured it, everything is fine. I tried to fly but the QuadCopter is not stable, it is very hard to control, has anybody try the RC2 beta?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This was my first test flight and i was using RC2 

  • Is RC2 beta the same as PiratesNG rev.527?

      I have been doing some bench testing with it and going through the config setup file.  As of right now It should be ready to go for my Quad.  I have flown less than 3 or 4  batteries.  I liked it.  The only problem was it had Yaw drift just enough to make it unstable.  The reason for the Yaw drifting was because of the compass.  U must get it all setup right or the compass will drift.  i noticed this while setting up the Xbee Telemetry.  Use the Artifical Horizion and compass to verify compass is not drifting and pointed the right direction with a compass.
  • I have a copy of RC1 here, send me a pm with your e-mail

    I will send it to you

  • Hello,

    I've experienced the same problems with rc-2. Rc-1 worked soo much better. I'm actually looking for a copy of rc-1 so that I can fly again..  Would you happen to have a copy of rc-1 you could send me? I've been looking all over the net. I seemed to have lost mine.


    Thank you,


This reply was deleted.


sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24