Hello guys. I’m writing about probably common issue, but didn’t find a way to solve it. The thing is, I connected my storm32 gimbal, configured it, but in autonomous missions with ROI (or follow me mode etc…) my drone doesn’t face on ROI anymore. Gimbal does, it tries as hard as it can, but the angles are only -90+90, and it looks on my landing gear :frowning: My WP_Yaw_behavior is set to 2, but in 1 it still doesn’t work and as far as i know 0 will just freeze yaw in one position and that’s not what i’m talking about, option 3 doesn't work too.

"" Points the nose of the vehicle and camera gimbal at the “region of interest”. In the example above the nose and camera would be pointed at the red marker.""
It is said in the ardupilot manual...


Same happens when using Circle mode, drone flies in a circle, gimbal tries to look at me, but drone still moves like a car on curve. Same with follow me, leash, look at me etc etc…
I’m using APM with 3.2.1 firmware with hakrc gimbal based on storm32
My gimbal settings are:
stabilize yaw checked
1000-2000, -90;90 (cannot excede those, becasue of gimbal possibilities), reversed

Views: 133

Reply to This

Replies to This Discussion

Hello David,   I have already done what you were trying to do an it does work. I have a 3 axis gimbal with a Storm controller. The only input I have wired is RC on the tilt. I control cam tilt with a TX pot or the AP can take control of tilt when in ROI mode.

I am not sure, but I think the gimbal setting to stabilize cam yaw it making it use the gimbal instead of the copter. The test I did worked just fine. The copter flew past the ROI and the gimbal tilt and copter orientation kept the cam in the right direction, with a little GPS lag. You need to set the storm to just take tilt inputs and stabilize the yaw and roll to the copter frame. The gimbal setting on the flight controller must be using the gimbal control instead of yawing the copter. I will have to look at all my params to give you specifics. 

Thank you for answer, Greg. Well, it seems that you are right, because some Time ago, before i bought gimbal, facing roi worked perfectly. I think MP makers should think about changing code and adding option to face drone and gimbal into roi, mostly because 3 axis gimbals cant often make a bigger angles than ~-100;100 degrees in YAW. Ok, so you Just disabled gimbal yaw in MP, by setting "none" for Input and Output Channel? But why did you have to enter Storm settings? I think the only thing we have to do is disconnect yaw in MP and drone should "know" that it's not having an option to face roi except facing it itself,like it was 2axis gimbal. Well, this option sounds realistic, but what I worry is that this drone facing roi is not that accurate like it Could be with drone facing and gimbal too, making it perfectly accurate. Have you checked this option with some kind of follow me, leash, circle modes? I'll try to do what you said and i'll connect my yaw cable directly to RX, so that i'll be Able to control it a little bit with TX, but it won't affect the drone. I'll let you know if it worked for me in thursday cuz I'm out of home for now. I Just Would like to know why you had to change the settings in Storm board App and if you tried it with follow me etc.

Hello Greg,

I finally did what you've said, so I disabled my YAW in MP and it seems to work queit good, but not perfect. I can feel the GPS lag on videos, because camera faces not actually perfect ROI, but a little right or left. I decided to help my gimbal and connected YAW directly to RC so I stil can control it manually a little bit, to help my gimbal look on ROI exactly and not affecting this dumb problem we've met. 

I've got solution from here: https://discuss.ardupilot.org/t/drone-doesnt-face-roi/34256/5

but it seems it only works with newer boards like pix etc., so my "old" APM classic board can't be updated to 3.6, just 3.2.1. Anyway, it's a solution, not really perfect, but still a solution. Can you give me any params you've changed or updated?

Greg Fletcher said:

Hello David,   I have already done what you were trying to do an it does work. I have a 3 axis gimbal with a Storm controller. The only input I have wired is RC on the tilt. I control cam tilt with a TX pot or the AP can take control of tilt when in ROI mode.

I am not sure, but I think the gimbal setting to stabilize cam yaw it making it use the gimbal instead of the copter. The test I did worked just fine. The copter flew past the ROI and the gimbal tilt and copter orientation kept the cam in the right direction, with a little GPS lag. You need to set the storm to just take tilt inputs and stabilize the yaw and roll to the copter frame. The gimbal setting on the flight controller must be using the gimbal control instead of yawing the copter. I will have to look at all my params to give you specifics. 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service