I removed Mission Planner from my computer, I was getting several pre arm check errors with mym2.8, I installed APMplanner 2, seemed super easy to go thru the set up, it was basically the same as Mission Planner, no errors, able to arm the motors, BUT, the throttle still acts funny, stick up just slightly and from idle to what seems like high rev, (what do I know tho, this is first build), saw a guy on YouTube with same problem but no fix, almost no range from just up from idle to 100% throttle, I put props on, hit the stick up and it revved, sounded sweet, I have Cobra Motors 2217/20 950Kv, stick all the way to the top and the thing won't budge, props are on right (1045s), motors spinning correct rotation direction, I'm thinking there is a setting either in the planner or the transmitter, someone out there knows, don't keep it a secret, let a fella in on it, lol, this is a new hobby for me and I'm a quadrotard, please help, any and all advice extremely appreciated

Views: 1022

Reply to This

Replies to This Discussion

Ive done it manually, one at a time, heard all the signifying beeps, do i need to do it again with the APMplanner2 that im using now?

No. ESC calibration is independent of the GCS software, in fact, you don't even need GCS software to do it.

But your problem sure sounds like ESC calibration related (not to be confused with RC calibration)

I hate to bring it to you, but MP or AP2 is only presenting you the pre arm checks, not evaluating conditions or trigging them, so while MP has many faults, (depending windows & .Net being among of them)  it's most likely that AP2 worked better for you by luck. (But it is, overall,  more reliable)



Andre K. said:

No. ESC calibration is independent of the GCS software, in fact, you don't even need GCS software to do it.

But your problem sure sounds like ESC calibration related (not to be confused with RC calibration)

I hate to bring it to you, but MP or AP2 is only presenting you the pre arm checks, not evaluating conditions or trigging them, so while MP has many faults, (depending windows & .Net being among of them)  it's most likely that AP2 worked better for you by luck. (But it is, overall,  more reliable)

I'm a noob so maybe I did it wrong, no power and no usb, disconnect the rc receiver channel 3, plug one of the ESC 3 wire connectors (I do them in order; front right, back left, front left then back right, I don't think its required but I'm like that, lol) to the receiver channel three, turn on transmitter, throttle stick up all the way, connect battery, listen for the cool tones, I wait until the tx and rx bind, then throttle stick all the way down, listen for beeps with a slight pause before the last beep, (which is the beep that indicates the ESC has been calibrated), then disconnect battery, then repeat the process for each of the other ESC's, I will point out that I turn of the transmitter between each calibration, not sure if that matters,  does that sound right? Oh, I was thinking about it earlier, my motor wires were really long and I didn't shorten them at all, I kind of doubled them up on each other and shrink tubed them, and because of my impatience waiting for the 3.5mm (soldered) bullet connectors I used 4mm (crimped) connectors, would that have any affect on my lack of power? 

Here's some pics of what I got going on

Attachments:

Update, I recalibrated ESC's, I'm using a 4s Lipo, should hear 4 beeps and a long beep, signifying the 4s battery and successful calibration, Right? well I only hear 2 beeps and the long one, same throttle reaction, idles and the slightest throttle stick up it revs high and no throttle control until stick brought down to nothing where it idles, this is with telemetry connected but not to mavlink, also when I use right hand stick and push right of course motors adjust but no upward motion, when I bank it left it comes off ground a little bit but the wrong side lifts, also, I switched it to Attitude mode on tx, it came off ground and tipped or flipped on its side, hope this is enuff info for someone more experienced than me to help me out

Dan,

I'm not an expert, and I don't use Apmplanner2, however, these are my thoughts.  Since your motors spin up I'll put the esc issue aside for now.

In Mission Planner RC calibration screen, you should see a full range of motion on all channels, if not, re do the RC calibration and check the setup of your radio ch 3.  Make note of the max and min PWM values for your throttle.

After your test flight, open the telemetry log and graph ch3 in and ch3 out.  Is the max and min PWM rate in line with the rc calibration values?

Your throttle sounds like it has expo (or some other modification) applied at the radio setup.  Have you reviewed the radio setup for every channel?  This might also explain why the wrong side lifts.

And finally, do you know that your selections of motors, props, and battery are viable?  Did you use a calculator like ecalc.ch ?  You did not talk about your all up weight, or goal for flight time.

The Logs should expose some good information.  If you can do a good test flight and attach the logs to your post, I'm sure someone on this site would look them over for you.  (I'm happy to look, but this site has some real experts)

An answer exists, you just haven't found it yet.

Ok, did i forget to mention that the red light on my external compass blinks all the time, i guess its supposed to be solid, now im learning on the 2.8 there is a jumper trace that needs to be cut, can anyone tell me if they have done this themselves? And could this be a source of my set up problems?

Fyi -my set up is a 450 quad alien spider frame, 2.4ghz radiolink tx , rd9 rx, cobra 2217/20 950Kv motors, G-sun 30A esc's pre flashed with SimonK, floureon 4s 6200mah 35c lipo, apm 2.8 kit (external compass, minim osd, 915mhz radio telemetry, power module), power distribution board, and a 5.8ghz diversity receiver set up from Hobbyking (dual antenna receiver, 600TVL 2.8mm camera, circular polarized cloverleaf antenna for tx, and 600mW tx) with an easycap so i can use my laptop as ground station, AUW is between 1900g and 2000g
Update, i opened my apm 2.8 (version 2.8.8 as the board reads) after watching a couple videos about cutting a trace between two pads, having some electronics assembly experience i felt confident that i could at least visually inspect the board, well, neither the I2C jumper is installed nor the mag jumper, and the layout was a little different than what I'd seen on YouTube, there are no pads in the position described on the Tube, and with the previously mentioned jumpers not installed i figured i hit another brick wall in trying to set this fc up, left a little more confused my curiosity had me checking out the board as i would have in my past work experience, my flashlight as a spotlight and a good magnifying glass were used but not necessary to see the fleck of solder crossing several vias on the back side near the analog pin's solder points, obviously overlooked during manufacturers inspection (if there even was an in spection done, it couldn't be missed) so with the fleck removed and a gentle wipedown with a cue tip and electronics cleaner im going to reset the board, uninstall apm planner2, reinstall mission planner, and start the process from scratch, i hope the board isnt fried internally somewhere and things go smoothly, ill update, of course any advice at this point will definitely be appreciated
Another update, the set up in mission planner went different, firmware uploaded same, set up of mandatory hardware acted different, seemed to go smoother at first, then during compass calibration mavlink kept disconnecting and the same comport was listed 3 times in the selection menu (could have been due to storms at the time which may have caused poor internet) getting a Compass 1 error but seemed to calibrate anyways (it saved some offsets and allowed me to continue) radio calibration was a pain having to reconnect repeatedly until i switched physical usb ports, then calibrated esc's individually, smooth progressive throttle wen checked individually after each was calibrated, then wen flight modes and failsafe were set i plugged motors in to output strip, and just as before, they arm and spin at idle, as soon as throttle is raised they blast up to a high speed, found a YouTube video of a fella having same issue, of course no solution in video just problem, here is link

https://youtu.be/SbleSREn2Ew

Any ideas?
I'll try to do screen shots of actual board data as suggested by Harry C if i dont get it worked out,

Thanks to all with their advice thus far, im not going to give up, its frustrating and a challenge, im up for it even if i have to get another board to compare,
Someone out there knows how to fix this, please help

Dan, Read the Wiki on telemetry logs and dataflash logs.  Screen shots wont do it.

The real experts may be able to help, IF you can attach the log files to your post.

Hi, I just experienced something similar with putting a Pixhawk in a fixed wing (P-39 Warplane). Basically what was happening was the Pixhawk would take too long to boot up and arm, and as a result the ESC would go into some sort of failsafe scenario and as a result it wouldn't go into calibration mode. I read somewhere that the trick was to use an USB connection (from computer) to pre-boot and then arm the Pixhawk first, and then plug the lipo in to the ESC. Doing this allowed me to correctly calibrate the ESC. Once the ESC was correctly calibrated, I no longer needed to pre-boot and arm the Pixhawk and everything now works as expected. Hope that helps.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service