Received my purple yesterday, just in time for Xmas ;)   Connected it all to my quad and it all seems to work (radio input, sensors, xbee).

What I can't get to work right now is the arming of the ESCs. I can arm the APM and verified outputs 1-4 with a servo (raw/radio view shows 1-4 output going up when adding throttle). But because the ESCs do not arm the motors do not spin up.

When powering the system up the ESC play the short melody. This is normally followed by a beep for each cell and then a long beep. However this part does not happen right now. Once in a blue moon, ESC number 4 arms and spins.

I calibrated all 4 ESC manually and they arm properly when connected directly to the receiver. Also tried to calibrate them with a trim offset to make sure they take a higher signal as 0 throttle. The calibration through the APM does not seem to work. The light do the dance on the initial power-up. But the ESCs do not seem to get the high throttle signal on the second power-up.

Could it be that my ESCs do not like the signal from the APM? It worked with APM1, KK and multiwii...

For now I'm out of ideas. Any input is appreciated.

Thanks, Andreas

Views: 8276

Reply to This

Replies to This Discussion

Found a workaround but it's pretty odd:

1) Power-up APM2 first

2) Now power up the ESCs

3) All the ESCs arm

4) Remove BEC used to boot APM2 (optional)

5) Fly ...

I still hope to find a better permanent solution. I found this work-around because I noticed that one out of 7 Turnigy Plus 40 ESCs always armed, none of the others did. The version printed on the ESC is the same (3.1), but the capacitors between the power connection are parallel to the wires instead of perpendicular. This is the only ESC in my collection that arms properly if plugged into the receiver AFTER being powered up. The other ESCs refuse to arm once they are in that state. I'm guessing that the APM2 output is "invalid" for too long during boot. The same ESCs worked with APM1.

I also found this thread related to the 400MHz update rate and first thought that it might be my issue. I applied the change to AC 2.1 but it did not change the behavior of my ESCs:

http://diydrones.com/forum/topics/esc-arming-problem?xg_source=acti...

I'm also having this same issue.  I have Plush 30's.  I can get one of the esc's to arm most of the time with APM2.  But the other three don't arm. 

I tried plugging them back into my old APM1 and they all arm properly. So, I'm not sure what is causing this.

My latest startup procedure is to boot the apm2 with the USB connection, then power up the escs. After that the escs beep normally and I can disconnect the usb and fly without any problem.

What to try if this workaround also works for you?

I suspect it's just a timing issue and the older turnigy escs are less "flexible/tolerant".

Turnigy has done some hardware upgrades. I recently found that the recent plush 40's have a Silicon Labs

C8051F310. The others have used a Atmega 16 processor in the past with the same ESC.

Maybe there is a mixing going on?

 

Mine are all Hobbywing Pentium 30amp escs which are clones of the Plush 30.  They are all the older design as I got them about a year ago.  They are all version 3.1.

As suggested by another forum member, I went through the calibration setup for each esc.  I did the manual calibration and the esc's are all arming just fine now.  Andreas, give that a try as it will likely solve the problem. 

Did the manual calibration and it did not fix it.Right now I just have to use the workaround of booting the APM via USB and only then the battery power.

 A friend of mine just got his APM2 setup and has the same issue. He is looking at the pin output in a oscilloscope to see if there is anything odd during the startup sequence.

I spoke too soon.  It only worked a couple times.  Now it's very inconsistent again.  Even with throttle trim at lowest position, it will sometimes arm one or two or even three.  If I recalibrate the fourth one, it will arm once. Something is still definitely very wrong. 

So, I'm glad your friend is looking into it with the oscilloscope because I'm not sure what is going on with this thing.  I never had this issue with the APM1.  In fact, when I reconnect the esc's to the APM1, they arm just fine.

Can you try my workaround if you get a chance?

Boot the apm2 via USB, only then connect the battery to the escs. This works very reliably for me. Just curious whether it's a universal fix.

Just gave it a try and yes, it works well.  All esc's reliably arm when connecting via USB first.

I wonder if the board is having a "brownout" when receiving power through the outputs? 

My theory: during startup the pwm signal is something odd that confuses the escs. Once startup is complete the signal is the correct "low throttle" value. Forgiving escs will just arm at that point. However my turnigys will not.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service