ESC arming issue (Turnigy Plush 40)

Received my purple yesterday, just in time for Xmas ;)   Connected it all to my quad and it all seems to work (radio input, sensors, xbee).

What I can't get to work right now is the arming of the ESCs. I can arm the APM and verified outputs 1-4 with a servo (raw/radio view shows 1-4 output going up when adding throttle). But because the ESCs do not arm the motors do not spin up.

When powering the system up the ESC play the short melody. This is normally followed by a beep for each cell and then a long beep. However this part does not happen right now. Once in a blue moon, ESC number 4 arms and spins.

I calibrated all 4 ESC manually and they arm properly when connected directly to the receiver. Also tried to calibrate them with a trim offset to make sure they take a higher signal as 0 throttle. The calibration through the APM does not seem to work. The light do the dance on the initial power-up. But the ESCs do not seem to get the high throttle signal on the second power-up.

Could it be that my ESCs do not like the signal from the APM? It worked with APM1, KK and multiwii...

For now I'm out of ideas. Any input is appreciated.

Thanks, Andreas

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Same problem here, i have it only with my 2.0 board and Turnigy Plush 30 escs. For now i am using a separate battery to power up the apm before aplying lipo to the escs but hopefully a fix will be created for this.


  • As far as I can tell this issue is back in 2.8 and 2.9. Arming worked fine for all my ESCs in 2.6 and 2.7.

    However with the current 2.9.1 version, several of my ESCs never initialize properly (the ESCs are a different "version" of the same Plush 40 ESC model). My workaround to first boot the APM with a separate ubec and only then power the ESCs still works fine but is a dangerous hassle.

    I went one step further and put a switch on the signal line of the problematic ESC. During boot, the switch connects the signal to ground. Once the APM is booted I flick the switch to connect the signal line. Then the ESC happily initializes.

    Since this problem was fixed in a previous AC version, it would be great to get that behavior back. ArduPlane 2.70 actually now has the same problem.

    Any insight on what was done to fix this problem in the first place and whether that fix was removed by mistake?

  • All my Plush 40 ESCs now all arm properly since AC 2.6.X.  I was so used to my UBEC jump-start workaround that I did not notice until yesterday. First flight with 2.7.1 tonight.

    Belated thanks for the fix, Andreas

  • i broke the red LED on APM2. APM2 iteslef is working fine. can someone tell the specs of LED on sparkfun so that i can  replace it by desoldering. thax

  • We're also getting this issue on a Turnigy Plush 60 (unknown version) on APM2 running Arduplane 2.33. Thanks for the hint on pressing the reset button, Stafford. This is a better "fix" for me than booting on USB power.
  • I'm also getting this issue on my APM2 with Plush 30 amp ESCs.  I've found that the only way to ensure that all ESCs are initialized is to let the APM2 boot and then hit the reset buttons a few times until I get the battery-cell beeps out of my ESCs.  They work properly after that.

    This is on Arducopter 2.5.

  • Just got my APM2 in. Ive had the same problem all day. I found a solution that worked for me. I reversed my yaw on my TX and then was able to arm the APM by moving down/left for 4sec. Then changed it back after to fly correctly. For some reason it will not work without being reversed. I even tried doing theorient side but never had any luck. I did find that I had to be in "unreversed" to disarm by moving down/left again. Moving to the right does nothing.
  • So, I received my purple board, hooked it up, loaded the latest coad with the mission planner, everything checks out, board arms but no response from motors. I also tried the work around it did not work. Any help much Appreciated.



  • Don't place LIPO battery voltage to the ESC's while configuring your build. When there are beeps it is important to NOT have propellers connected. Just being safe:-)

  • So far no good. I really wanted this fix to work. But I'm still seeing the same problem that the ESCs do not arm. The workaround of powering the board first and then the ESCs still works. I had to do several rounds of erasing/resetting/uploading until my APM was working again.

     @Vishal, did your ESCs arm or were you just happy to get over that leveling issue?

    I always calibrate my ESCs manually. The new APM way never worked, but I'm guessing it's related to the ESCs bad state. Would this be the correct sequence?

    1) Full throttle

    2) Power ESCs / APM, wait for lights

    3) Power off

    4) Power ESCs / APM, wait for lights

    5) Zero throttle

    6) Power off


This reply was deleted.


Santiago Perez liked Santiago Perez's profile
17 hours ago