ESC's keep beeping continuously and endlessly!

So i fully assembled an OctaRotor MultiCopter, connected the ESC's, motors, APM and battery. Did an ESC calibration and everything is working perfectly but even at full throttle, there is no takeoff! The prop sizes and ESC's and motors are as recommended by the website from which i bought the Octa frame, so i decided to replace the battery with a bigger one.

The current battery is a 35C 3S 5100mAh 11.1V, i removed that battery and placed instead a 6S 9000mAh 22.2V battery. As soon as i connected it, the ESC's kept beeping continuously and endlessly! I tried to re-calibrate the ESC but that didn't work! (Even though i know the calibration worked because of the flashing blue and red LED on the APM). I reconnected the old battery again and everything was good, the Octa was responsive again.

Does anyone have an idea why the ESC's keep beeping when i install the 6S battery?

ESC's : DYS 40A continuous 

Motors: T-Motor MT3515-15 400KV

APM 2.5

Futaba RC

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • if anyone is still interested, the solution to all this was to change the ESC to the HobbyKing Platinum 40A which most definetly can handle 6S Lipo.

  • Solution is written BIG on the product website I found:

    • Compact 40 amp Brushless ESC

    • With builT-in 3 amp BEC

    • 40 amps continuous, 45 amps burst

    • 55mm x 26mm x 11.6mm, 35g plus                         

    • Handles up to 12.6V   <------------------------------------ Your ESC only handle up to 3S

    • Programmable LiPo or NiMh cutoff

    • Programmable brake

    • Low resistance

  • anyone? anything?

    Your help would be much appreciated.

This reply was deleted.