Hi, all..

Here's the situation before i tried to calibrate:

2 (out of 4) of my ESC constantly beeps after boot, like around 1 beep/second (or slightly slower). But then i just thought it just needs to be calibrated.

I'm following this: http://code.google.com/p/arducopter/wiki/AC2_ESC

Auto calibration doesn't work.. When i tried calibrating manually based on this, it gives the same constant beeps; even if i move throttle up and down. Also, all the motors don't spin during calibration; is this how it's suppose to be?

Does anyone know what my problem(s) is/are?

Thanks a bunch, guys..

PS: i'm a kid. I sure am a newbie..

Views: 53121

Reply to This

Replies to This Discussion

I had trouble calibrating after loading the latest code last night.

Make sure your radio is calibrated first is my only suggestion.

the radio is calibrated and it shows everything works fine with it.. only then i stepped to the next step, calibrating the ESC, where the problem above occurred.. how did you manage to calibrate in the end?

Well like is said I had just loaded the latest code.

I was getting constant beeps from the ESC's when i connected the battery.

So I did radio calibration.

I tried the four at a time calibration. Set throttle to full then connect battery.

Disconnect battery.

Set throttle to full.

Connect battery wait for  final beep then lower throttle to min and wait for beep.

Then put the throttle up again and the motors should spin.

Then it worked for me.

Mind you I had several attempts but I think initially it was failing because the radio wasn't calibrated.

Good luck and keep trying.

Its either that or the signal is not getting through the power distribution board.

The thing is, I tried the calibration manually. Which means the the power distribution board really has nothing to do with it. Cause the lipo battery is connected straight to the ESC, and the 3-plug cable from the ESC is also straight connected to the radio receiver.

Anyway, thanks for the advice man, i'll try again sometime soon after charging my lipo battery..

In the mean time.. if anyone else out there have any idea what's going here, your input is much appreciated..

What ESC's? I bought 4 from Hobbyking recently and 2 didn't work, just beeping continuously. The other two are fine.

If they beep twice then a pause then twice again then the signal is not correct. You can try calibrate the end points, reverse the channel or something is wrong with the ESC's.


Don't really know what ESC's they are.. they come with the arducopter in the order as one package.

and, nope, it's not the beep twice with pause..

Uhm.. I'm sorry you lost me on ur last question.. what do you mean by "You can try calibrate the end points, reverse the channel or something is wrong with the ESC's."

thanks man..

Check the wiki page again, I've made some changes to hopefully make it easier to follow. The manual ESC calibration part....

ah yes, that's clearer now (those 6 steps) and i will try them as soon as my battery is charged!

2 small and silly questions left..

how do you "Make sure your transmitter end points are set at +100%/-100% if applicable. " ?????

by any chance you know what the ESC's constant beeps means? (like 1 beep/second or slightly slower)

Thanks, Graham..

If you have a computer transmitter then the end points are adjustable, don't worry if not as they are then set at 100%

i see, well i guess i dont have to worry cause i'm using a remote controller? am i correct?

and no clue about the beeps, is it?

Thanks, graham.. appreciate ur inputs..

remote controller = radio transmitter

if yours is programmable then the end points need to be set at 100/100, that is the default otherwise don't worry.

the beeps come from the motor but are made by the ESC

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service