Hello everybody. I have an APM 2.8 with Emax ESC 30A Blheli. And there's the problem. At the beginning, when ESCs were connected to RX on my AT9 Radiolink, they seemed to freeze for a milisecond and kinda freeze or shake. I didn't consider it as some serious problem because they (supposedly) are made to work properly just if used with a flight controller. So I put my quad all together. What came up? ESCs do not want to calibrate with the APM 2.8 unless the throttle lower value is 900. It makes a huge problem because I can not use failsafe then as it's lowest value can be 925 (correct me if I'm wrong) and if i calibrate it like that (changing the endpoints on TX and a little trim) motors stop at the highest throttle. I've been struggling with this problem for more than a week now and I have completely no idea what to do next. Maybe it is the ESCs that are faulty? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks a bunch, I once saw a topic that said you need to remove something, but I haven't found out what until now. I'll test this in the future, when I get some free time. 

  • You need to remove one resistor and one capacitor from ESCs and will work perfectly on APM or Pixhawk

    unspecified.jpg

  • Hello Grzegorz
    Your solved the problem? I am in a similar situation. :(

    APM 2.8
    Flysky I6 - IA6B
    Emax ESC 30A simonk
    DJI 2212-920KVmotor

    First scenario:
      ESC calibration by the RX Channel 3 .... everything perfect, no need to trim TX.

    Second scenario:

    Calibration ESC connected to the APM, when I try to calibrate, after 2 beeps of max_throtte, when i ser the throttle to a minimum .... do not hear the beeps ... start using the trim ... when I get to -120% of the minimum, I hear the beeps and esc synchronized (the value is 900)

    In this way, I lose FS configuration.

    Any possible solution?
    Thank you very much.

  • How about to do throttle calibration

    Remove your props! and disconnect the battery. Push your radio throttle to
    maximum, connect the flight battery, You will hear 3 beeps: di da di (ESC
    self-detection finished). wait for 1s, you will hear a short beep: di (ESC is
    ready to do throttle calibration). Now lower the throttle to minimum. You will
    hear another unique 2 beeps: di di, indicating hrottle calibration completed(If
    you hear a short beep, it means throttle set failed. You need to do the calibration
    again).Then a long beep di--— tells you ESC is ready to work. Disconnect the
    battery. throttle calibration is done.

  • Yes, I have, and it all works perfectly. But then when I connect it to the APM it beeps as it beeps when there's no signal (4 beeps a second). I have also checek other ESC (Emax Simon Series) and it works flawlessly.

    Tim Dickinson said:

    Have you tried calibrating the esc without the apm?

    Grzegorz Radziwiłko said:

    I have already reversed it along with pitch i believe.

  • Have you tried calibrating the esc without the apm?

    Grzegorz Radziwiłko said:

    I have already reversed it along with pitch i believe.

  • I have already reversed it along with pitch i believe.

  • If your motors stopping at the highest throttle might be that your throttle need to be reversed. I have an at10 and found that I needed to reverse the throttle. Otherwise when the throttle is at low its really at the highest point. 

    What does your radio calibration look like?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
yesterday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…