FBW_A and Stabilize don't agree on Level [solved]

Hi folks,

On the bench: When FBW_A is enabled, all control surfaces level off when I tip the plane 20 degrees up and roll it about 30 degrees right.  When stabilize is enabled, all surfaces are level when the plane is level.

In the past, I've seen this load of APM2 (version 2.40) operate FBW_A and Stabilize agree on where level is.  Not today, though!  You should have seen the flight!

How could these two modes not agree on where level is?  How can I fix it?  Does FBW have some memory of trimming I don't know about that stabilize ignores?  

Thank you,

spag

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I've figured this out.

    It seems that using manual level does not update the offsets for both fbw and stabilize; just stab is kept current. If you allow the plane to level everything at boot, both modes will agree.

    I discovered this after the problem followed me from 2.4 to 2.6.

    The most effective solution is blowing away the config and starting over. I simplified this by taking a screenshot of the PID's before clearing the config, since that's the most time-consuming part to redo.

    Then I erased the eeprom by entering terminal mode and typing 'setup erase'. Then I restored to factory defaults by typing 'setup reset'. FBW and stab agreed after that. I just re-entered my PID values, recalibrated my radio, set the modes, changed settings here and there, and done. 10 minutes, tops.

  • Is there no other APM2 user who has or has had this issue?  Is there an expert who can shed light on how the feature works internally?  Perhaps there is a thing that needs to be cleared, or... some other such thing?  

  • Hi,

    A couple of weekends ago, we were also messing with APM2 and arduplane 2.5, and found all kinds of weirdness with level settings between stabilise, and FBW/auto.  

    The last thing we had changed was to using the "level" option (which remembers the level set across bootups).

    Going back to using normal re-leveling on each boot seemed to fix the problem.  Didn't look much further into it at the time as we got busy flying :)

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…