Developer

figuring out the Antenna Tracker

3691139590?profile=originalNot many people know but we have an piece of open source software for controlling an Antenna Tracker.  It's been built by Tridge (Arduplane lead developer) for use in the outback challenge.

Sadly we have no documentation and, as far as I know, nobody except Tridge has used it.  Still given Tridge's track record on building great software I suspect it works well and if it doesn't, I'm sure we can fix it.  So to not let this piece of code go to waste, I'd like some help from people who are interested to give it a try and help me figure out how it works.

Here's the little that I know:

  • It runs on any of our supported board (APM1, APM2, PX4, Pixhawk, Flymaple and perhaps VRBrain)
  • For APM1/APM2 users building the code is as easy as opening our hacked ArduinoIDE and selecting File > SketchBook > Tools > AntennaTracker and then building in the normal way.  For PX4/Pixhawk, our autobuilder doesn't automatically build a binary but I can provide one if people are interested.
  • It can control a Pan and Tilt gimbal like this or this found on servocity.com.
  • It may or may not require a GPS
  • It must somehow receive vehicle position updates from the ground station which has the telemetry radio that is connected to the vehicle. Maybe through a USB cable.  Tridge probably uses the python ground station, MAVProxy, to passthrough the vehicle position data to the AT but perhaps we can get MichaelO to build out a similar feature in Mission Planner.
  • I imagine this antenna tracker could also be used to keep a camera focused on the vehicle which might be good for easing the burden on creating videos of our vehicles.

So if you want to give it a try please do and stick any findings, questions or issues below. Alternatively Issues can go into the issues list.

I'll start sticking things into the wiki as they become clear.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • Developer

      Mike,

      I haven't used the bluetooth modules on the antenna tracker but it works fine on a copter.  I can't imagine any reason why it wouldn't work and it's a cheaper and easier solution for the AT<->GCS jump.  It's slighly lower bandwidth than the 3dr radios (38k baud vs 57k baud) but I don't think it will matter.

      One thing is I personally had some problems getting the bluetooth module to work with my windows PC running mission planner.  It was/is a mission planner issue, because the same modules has worked fine on my android tablet running droidplanner2.

  • Today I tried AT 0.3

    Unfortunately I can't see any Improvement.
    Telemetry 2 is still not working. There are absolutely no Data even no Heart beat.
    The HUD from the Copter (AC3.2) is not updating through the AT.

    Also there is no GPS fix at the AT but the GPS itself shows me a 3d fix!

    • Developer

      Andre,

      The fix for Telem2 isn't in master yet.  It's only sitting in my febe-gimbal5 branch.  I'll merge it to master later this week and push out AT0.3 as an official release before the weekend.

      • But in Missionplanner I can load AT V0.3. What are the changes of these V0.3?

        • Developer

          Andre,

          Ah right. I'd forgotten that for antenna tracker goes straight out to the mission planner with no release management!  We will fix that.  Ok, so now that 0.3 has snuck out, we will name the version with the telem2 fixes "0.4".

        • He put the mavlink routing stuff in, but the telem2 fix isn't in yet.

  • Distributor

    I am stuck ...

    one question at the side - if I use a 3DR uBlox GPS with compass, do I connect the compass to the Pixhawk? Or do I only use the onboard compass of the Pixhawk?
    If I have to use the compass in the GPS unit - where do I mount the GPS unit? If it is mounted on the tilt axis, then the GPS will have a bad signal if the tracker points upwards;
    if I mount it on the frame of the tracker, then the 3axis compass of the GPS unit will not tilt - thereby the values will be different than the values of the 3axis onboard compass of the Pixhawk ... (I hope you understand what I mean).

    I have built the tracker, the tracker (Pixhawk) is connected via USB to my computer;
    the tracker is connected via telemetry to my copter.

    I get a green blinking light on my Pixhawk (on the tracker) - but nothing else happens.
    If I press the safety switch the light keeps on blinking green - no movement of the tracker.

    • Developer

      @Felix,

      I use the pixhawk's internal compass on my setup.  It's fine to use an external compass (like the one in the 3DR GPS+compass module) but this compass must move with the pixhawk so it needs to be mounted on the same moving platform that the pixhawk is on.  With my particular setup it's difficult to mount it like that and still have the GPS pointing upwards so I've left the compass wire (the 4-wire I2C line) disconnected.

      The green blinking light means that it's got it's own position.  Once it knows the position of the vehicle it will go solid green.

      • Distributor

        @ Randy - thanks for the information.

        My vehicle (3DR IRIS+) had GPS lock and was armed - but the tracker just kept on blinking green.

        On the mission planner I could see the position of both, the IRIS and the antenna tracker.

        Putting the tracker into auto mode or scan mode didn't change anything. Only in manual mode it drives until it reaches the maximum position.

        • Developer

          Felix,

          On the MP, if you select Ctrl-X and then select the copter from the drop-down, do you see the attitude in the HUD change as you tilt the vehicle?  I'll bet you don't.  This means that the position and attitude is likely not updating.  In this situation if you disconnect with the mission planner and then connect again it should work.  The last thing to check is on the MP's Config/Tuning screen on the "Planner" screen there's a row called "Telemetry" and it has 5 drop-downs named "Attitud", "Positio", etc.  Make sure those are all non-zero.  set them to a number between "2" and "5".

This reply was deleted.

Activity

DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
More…