Hi all,

I am having problems with my board. It was OK and I was flying perfectly my plane until yesterday, when I tried to upload the latest firmware 3.4 and when it was about to finish, the message  "Upload succeeded but verify failed: exp C got 14 at 0" appeared. (I uploaded firmware with GPS and compass connected).

Now I can´t connect with MP anymore. When I connect USB, the Power led is on, but the ABC leds (red, yellow, and blue) are always off. If I try to upload Firmware the RX and Tx leds blinks.

I tried with another computers, checked the parameters in the COM port, used APM Planner, but nothing works.

I regret I tried to upload the firmware, it was working ok until yesterday! If something works, don't touch it.

Anny suggestions? Sorry if my english is not good.

Thank you!


Views: 236

Reply to This

Replies to This Discussion

Looks like your flash storage is broken.  When the firmware uploads it does a verify to ensure what was written is correct and yours has failed that check.  Note this isn't anything to do with the ArduPilot software.  This is the process of uploading the software - you will get the same error no matter what you try to upload.

What kind of board is it?  You might be able to RMA it.

Thanks, Grant.

Hi Grant,

I ordered an USBasp Avr Programmer to try to flash the APM boot loader. Tomorrow I would have it.

Let's see if it works.



Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service